L— . o 3l
EA—#ﬂ—‘ﬁI—?ﬂ—ﬁé 3l
Ktep 1+ & A WICE 3]
}Step 2. 3 — @t £ (Project): 4]

6l

gl

7l

22 3 1h 4k 8l

Ktep 7: 4242 % # 2_ICE gl
Ktep 8 P44 (Step Into) 8|
by ql

Ktep 10: #1147 Go ql

40 2% g7 3% 4 e 39 ok 4o 10l
|2 35 /—\? 3 EIJ (Q‘mhﬁmpnf Qyn‘rm() 1“'
.—\—.;5:;.,: ‘J“’E%TT‘ 11|

k #2 X 35 = ( Program directives ) 13l
k 4% ;j$ 2 28 ‘z‘%( Conditional assembly ) 1 Rl
|7 A=) ?( Reserved word ) 7ﬂ|

h 2% '.'1‘:: ﬂ':' &}"rl@_‘l‘:(QPf hrpn](pninf) 21 |

|2 $h 472 X (run program) 71'
N Ir O 7

54 2 (Menu) 22l
|7 T E‘ 51} (Tnn] hqr) 7'2'
h ﬁj&(nnnnprt) 72'




’)Al

b4 % ob 4 (File menu)
\ 7
k4648 25 45 (Edit menu) 20l
— A=,
I 3+ £ 7j 4& (Project menu) 36
E U g o) 4 (nphng menu) '%Ql
b T A8 (Toolmenu) 44
|||| ;‘g ﬁ:g é{; %"‘Sl‘r (Ontion menu) Aﬂl
AN i U
h 1 Z‘% (Winﬂnuz) Agl
o % Ba(Heln) 49)
A M r7
I;\; ~ 443220 8 (error message) ﬂﬂl
*z . 2 b JEupy. 23 §ﬂ|
b_A $A. g 2E RIS L phhdeg o 52]
K 33 4 2 22 o §7|




—_~ {l\ﬁg

WICE £ —%&4 Win95 & Win98 1F % % 4 T #4789 &% 8 fr uidE 4 %5 Window kg ICE %%
SRR RE (A% 3t ETEProject) ~ M3F ~ ) KRB - R BIRG > LiBS
BET—F0%h &N ER WICE- WICE 2 EWBRANEERALHEER - XHEF S5
REA R G s R A A2 A a9 FE M o

4 WICE 2.0 £ #4 & A F B34y -

|

~ So ] B 46
 413% (assembler) $ii# 4 (linker)
s 4% (debugger)

~ WICE #3314

i

F M B

N
7

v 453530 8 (error message)

» R

r\.

WICE & — & 3t & (Project) iy ey B S RIS 8B, ¥ 46 7 %3 - 3t £ 4 2 (Project
manager) ~ 4 3% R P44 B ob etk A £ E ho 12 0 oy e L3RR % 48 i1% 4 > 4o Editor Av A F K (find)
B 4X (replace) ~ undo ~ redo ~ B T (cut) ~ # B (copy) & Bk k(paste) » R IRBUFE A TS 5 &
AR 4542 X p 4 &R 4 3E % v A HE AFE E(include) ~ E % (macro) ~ 4 3% 85 £ 3% & (assembly
arithmetic) ~ #&#F 5\ 42 3% (conditional assembly) ~ list file & map file % -

BT AR AES 0 WICE BAu N T3R4ER 7 @BAF &AL > 4o & R]3EA2(block comment)
EBRGHYHFE ABERAFNHAERNE L ICE SR E% - WICE %4 B 23R RAHE
& R Reyie MIRIE ~ B4 A ayshre R R bhik R 48 2 &) ICE 3B3% -

=~ o fTH %

—fxAE A E B —EM KA B A F — B AR ho T B 46 4R1F - T WICE &3t £ § &8y ICE
SRR 0 B AR B 9L R B4R A o 7 B 632 3 — {83t (Project) » o {36 Ao — B HTHE
B3t E b REMwCAFEGHREE > R ko T43F S I — B HARAE(CDS code) » %
Yo {745 A ARRSE T AE ©
Step 1: ## A WICE




5 ik — 7T LA B 4#(double click ) £ & 49 EMC WICE #) ] = (ICON) -
Fik =R IE[ ][22 X E] =[EMC WICE] —[EMC WICE 2.0]

Connect

Micro Controller : EM?EIEIH ICES11 _,|

Connect Port: [378H ~

| cancel |

LkekkEad
Step 2: #73¥ — 183 & (Project):
1. :#4Z[File]>[New...], Ba-w#73% a4 ¥ 3% & (dialog) -
2. ##F[Project] tab.



File Edit ¥iew Project Debug Tool Option Window Help
New ﬂ
File  Project | CONT: 08
R10:00 RO(A,V):00,00
. R11:00 R1/TCC:00
EMC Project File(x.prj Project Name: R12:00 R2/PC:0000
|t95ﬂ3]] R13:00 RZ:00000000
R14:00 76543210
Location: R15:00 R4:00000000 Pagel

|C:\Program FilessEMCAEMC_WICE |

Micro Controller:

[EmrBB1I0CEB )

[ |

T 8 9 A B C D E K=
00-00 00 00 00-00 00 ¢
00 ¢

00-00 00 00 00-00
00-00 00 00 00-00 0o ¢
00-00 00 00 00-00 ee:iﬂ
Y| 4
Ready VR NUM
2: #¢[File]>[New]#73¥% — 18 Project

4,57 3% # [Project] — [New...]

Debug  Tool

Edit ¥iew Project

D@l ol o [mle) o] el o] <le] mmlln] | |

Eile Option  Windew Help

put =

CONT: 08
RO(A,V):00,00
R1/TCC:00
RZ2/PC:0008
R3:00000000
76543210
: 00006000
;B0 C5:00
;00 C6:00
;00 C7:00
;B0 C3:00
:00 C9:
100 CA:
:00 CB:
:00 CC:
:00 CD:
;00 CE:
:00 CF:

Project Name:
Itestﬂ]1|

Location:

IC:\Program Files\EMCAEMC_WICE

Micro Controller:

[EmraaTI(CER)

[ o]

[ |

Cancel

3 4 5 86

00-00 00 00
00-00 00
00-00 00
00-00 00

nAn_nn nn

00-00
00-00
00-00
00-00

Ao nn

00

00 00-00
00-00
00-00

00-00

nn_nn

3:4#%[Project]>[New] #73% — 18 Project

T 8 9 A B C D E &
00 ¢
00 ¢

0o ¢

00
*H 4




Step 3: ¥ —EHEEFHERWAA CHENEE)
1. #2[File]>[New...], B85~ #7 3% a4 3 & (dialog) °
2. #E#[File] tab

File | Project|

EMC Source File(*.dt V¥ Add to Project

EMC Header File(=.h) ; ; :
Text File(x.txt) Project Name:test811.prj

File Name:

[test1]

Location:
IC:".Program Files\EMGIEMC_WICE |

OK Cancel |

B 4:3F5 3 — B 4% &=

Step4: #HH¥—EEEE2HEBELCLFLHBITHEDR)
1. #E#[Project] —[Add files to project...], #&-~ open file ¥} 3% & (dialog) °
2. BEH A project B94EFE > EIx OK %4



E (D

I A Eme_vrice

_1bin
_Jexample
[ Jimages
Jinclude
=

T8 S= ST
BB

Jtest.dt

IEMC Sonrce Files (L dt;asm)

CE

YR

Step 5: 42 X

5:3% /u — 18 % 4% 2| Project

ted

Eile Edit ¥iew Project

Debug  Toel

Cption  Window Help

D|=d|e] @l 2lesle] =]

“roject
& Files

- [E] CiProgram Files\EMCEMC_WICE\est].dt)

] References
"] List Files
1 Map Files

= N e e o

Al
=

a,@exe2
0x20,a
0x20,a
ox21,a
Bx20
Bx21
start

CONT: 00
RO(A,V):00,00
R1/TCC: 00
Rz/PC.0000
R3:00000000
76543210
e lolololololole]
i C5:00

Pagel

Eeady

0: 442 X,




Step 6: #3F g &

#4#[Project] —[Rebuild All], Output % & B~ @FRELHNEL

File Edit View Project Debuz Tool thion Window Help

DIOJBCT.
& Files s ;
wfEB] C\Program Files\EMCEMC_WICEMest].dt mou a,R@0x02
1 References

mouv 0x20,a

& List Files

* Bl C:'PROGRAM FILES\EMCIEMC_WICET mou 0x20, 4

& Map Files I!IOU 0x21.a

“[E] Ci\Program Files\ EMC\EMC_WICE\estg11 inc Bx20
1hc Ox21
jmp start

CONT:08

rS
RO(A.U):00,00

R1/TCC:00

Rz/PC:0000

: 00000000

76543210

: 00000000

Pagel

7. 4AER R

Step 7: £ KX # A ICE
% #[Project] =>[Dump to ICE]

Dumping ....

8: #F A2 #; A ICE
Step 8: Fx4&(Step Into)

2

El Cutput Window _ O] x| I Ei

Assembling . .. 2 3 4 5 6 7 8 9

C:\PROGRAM FILES\EMC:\EMC_WICEA\TEST1.DT BO_2X:00 00 00 00-00 OO 00 0O-00 OO OO 0O-00 0O GO O

Linking ... BO_3X:00 00 00 00-00 OO 00 0O-00 OO OO 0O-00 0O GO O

0 Error(s), 0 Warning(s), 0 User(s) B1_2X:00 00 00 00-00 GO GO 0O-00 GO OO DO-00 0O 00 06

B1_3X:00 00 00 00-00 OO DO OO-00 OO OO0 OO-00 OO OO O0G
B2_2X:00 00 0O 0O-00 OO DO OO-00 OO OO0 OO-00 OO OO OG
B2_3X:00 00 DO 0O-00 OO DO OO-00 OO OO OO-00 OO OO OG
B3_2X:00 00 0O 0O-00 OO DO OO-00 OO OO OO-00 OO OO OG
B3 3X:00 00 DO 0O-0O0 OO DO OO-00 0O OO 0O-00 0O

ol | KA

Assembler OK || [Ln 4,Col 0 lovr | NUM



#E #[Debug]
Step 9: % P Bf

—[Step Into] &

A AT B F P BT oY RORAE (B4 4 dt 2 asm) 0 A R E R

# #42(Hot key) [F7]

(Double click).

File Edit Yiew Project Debug Tool ©Option Window Help

| 21T es||a|3|g|

%m%t org 0x0

& Files ] start:
E] CProgram Files\EMCOEMC_WICE test1.dt

1 References mgz g;ggxgz
& List Files i

[ CAPROGRAM FILESEMCEMC_WICEAT mov 0x20,a
& Map Files mov Bx21,a

© [ CiProgram FiledEMCEMC_ WICEvests 1 | TS

inc 0x21

jmp start

Sl o] 4[C _I“'I_IT*_I*I_I"" _I_I

CONT: 2F

rs
RO(A,U): 00,00

R1/TCC:E1

Rz/PC:0000
80011011
76543210

R3:

: 00000000

Pagel

—olx]|ETE
nssemb11ng - 12 3 45 86 7 8 9
C:\PROGRAM FILES\EMCMEMC_WICEATEST1.DT BO_2X:F9 57 FB OD-EF 73 DF EF-5E FB EF FE-8B TF
Linking ... Bo_3X:BS TF 5F 6F-FT C9 F9 3D-BA DF FF D5-FF CC
8 Error(s), 0 Warning(s), 0 User(s) B1_2X.DF DF DF FB-FF DF SB FF-3E EE ED F6-C9 C3
B1_3X:T7F FF TF BB-51 FD FF FF-67 F7 3F 67-6E FB
B2_2X:35 8B 9E DE-FF 5B BE EB-CF DF FF F2-C6& BF
B2_3X:57 F3 AE FD-77 1F 94 TA-FD AT B4 DF-6F 9F
B3_2X:BO® 2F 9F TF-FE DF 7D BB-FF 6F 57 7A-D7 DT
B3 3X:F9 2A EF FE-FE 77 FF FF-T7B FC C7 CE-DD BF
<« | K
[Ln6gal 7 s |
Bl 9:3% 5% o BT B

Step 10: #.47 Go

% $#[Debug] —[Go] &£ ## Hot key [F5]

Step 11: £ 7 step5 Z step 10> AP X E#H# AL



Z~agngs
l. aFRBLEREME

—)j "j *.dt or *.asm
P P AN— 8 Including files

v A\ 4

......... > B e P List file (*.1st)
Obiject file (*.0bj)

EMC Linker

AAAAAAAAAAAAAAAAAAAAAAAAAAA » Map ﬁle(*map)

Target file (*.cds)

2. 354 #.8](Statement Syntax)
[label [:]] operation [operand] [,operand][; comment]
b5 INAR EAE TN &Y 9 A 7T A T & B 4% 3¢ (label) 3 B F(operation) 3% & 7t(operand) Fo
A (comment) N F A EXNEE S > MEE (iR EEF)ARE G R
152 (Tab)E [ ©
#it(label): #ZemeER (1) THTE  EERFRARTE R ZMER  £THEEL

BAFRE  EZRTARBEEIUTHES  WREZ-—TEFZNWLEER  UERFLHE

10




BB ERRS RREERRERNEAIFF BFRERE LA A~Z
a~z> 0~9 fo_ 09 BFAREERLE —BAFHELRTKAEKSZ 31 AT -
¥ B F(operation): @35454 (instruction) A& #§sw(directive) @ 35 4 & 45 7T 40 3% R A% 055
&)X F 4o mov a,@02 > 5w (directive) & 35 R AFEMMABHIXF » T EATER
Kkt 8 @4 K&t 40 org 0x20 -
EH ju(operand): EH Uah B S4F M X F R ARIEE H T (operation) i £ > L AR
BHEFREOG Y EHAAET A MARER () B
EAE(comment) 3EAR G E R ARER L ABRLLERANER  7ERZARXIHZBAT@®
RIS BR L - E oy B —F8 > 4734 (line comment), & 3% 3 A2 (block comment) °
TR UNR () ARBANE —FL > A7RIKET —TAHLGHTA T
¥ B 3ERR > 54 test comment
& 332 A% (block comment): & BB\ #Hag e 258 (/%) B ESRmAteg (¥) > 4F AR
ATfE 0 PREIATA X FR I A 0 RL 6045 24T X F 327 0 Flho/*  test

comment */

3. BFEHBEET

AR A (ahik— |REAAE= |RTFEE
+ it %] (Decimal) 0D<digits> <digits>D <digits>

+ 75 it ) (Hexadecimal)  |0X<digits> <digits>H

A i (Octal) 0Q<digits> <digits>Q

— & #/|(Binary) 0B<digits> <digits>B

3 i bR <digitH &8 0 ZHFE BT L A~F K a~f B EABFAT/EO -
EERTHE—BEEER, AORT A E—AELEE -

4. #a3F0% e 32 E H (Assembler arithmetic operations)
MAEFBEEE XA THAERE A L@ FHRYIFLARTELER > FRIG A £ 435%
FEENFAER > SRAFEEN A AKA SR AEHRE -
#(TRUE) #0948 (FALSE) : 4 OXFF &7 & » 3 0x00 % =18 o
LA P75 49 8 3€ B T (operator) & LA 3t BAR LR R HE 7 o
(1) 23 ( FoEFEIN )

11




(2) R & —18:& & ;v vy & E 7 (Unary operators)

!

Jk(Logical NOT)
#4 #( Complement )
#%&( Unary minus )

(3) & ~ I~ BRB A AL
* & ( Multiplication )
/ M ( Division )
% £23.( Modulo )
<< A #(Logical shift left)
>> # # ( Logical shift right )
(4) Au ~ R
+ Jra
- R
(5) L7t AND
& (BIT AND)
(6) /£t OR A XOR
| 4z OR (BitOR)
A frst XOR (Bit XOR)
(7) #&#§ AND
&& ## AND ( Logical AND)
(8) ##F OR
| ## OR (Logical OR)
(9) tb#(Comparison)
== % 7 (equal)
I= 7 ZE#(not equal )
> AR ( greater than )
< /I (less than )
>= KA % 7 ( greater or equal than)
<= %R (less or equal than)

12




5. # X 355~ ( Program directives )
(1) ORG : & & #2 5,31 #L % ( program counter ) &9 f& °
3E%: ORG  <expression>
4. org 0x200
(2) EQU or == (Duplicate =): % #:3% &
&7k <label> EQU <expression>

f]—: R20 equ 0x20

5] =—: R20 == 0x20
(3) x4
473:x # (Line comment)
Tk, <string>
f]4ao: ; this is the comment string.

& ] 3£ 42 (Block comment)
Tk /¥ <strings> ¥/
f]4e:  /*  this is block comment

example including multi lines */

(4) EOP : 1542 X, ROM Page &4 4 % (end of page) °

&% EOP
IBCH
org 0x10
mov 0x20,A
inc 0x20
eop
inc  0x20
4832 R T % &Y 4 F(source AT % address):
org 0x10

0010 mov 0x20,A

13




0011 inc 0x20
eop
0400 inc 0x20

(5)END :#2 X% % 4 END 2 #% s f2 X 3y R 43¢ -

5% END
5] %o
org 0x10
mov 0x20,a
inc 0x20
end
mov 0x20,a

48 3F T 7 84 & X (source AT 2 address):

org 0x10
0010 mov 0x20,a
0011 inc 0x20
end
mov 0x20,a

(6) PROC,ENDP : 2|2 X 698 & » Hiwa| 2 Xy TH % -
3% <label> PROC
<statements>
ENDP
18] do :
BANKO: PROC
BC  0X04,6
BC  0X04,7
RET
ENDP

14




32:PROC % ENDP R &3 /mg|f2 X a9 T EE > AT RET £ 2lf2 KB A L8,

(7) INCLUDE: AR R > BEXEABHREREHE -

INCLUDE: 5 & 48 » —# 4 %4R4E6e) INCLUDE % > 7 —fAMERAE A THEEY

INCLUDE #% £ -
a. 1 A % %324t 4 INCLUDE 4% % » 4» EMC456.INC » EMC32.INC

32;%: INCLUDE <filename>
f5)4o: INCLUDE <EMC456.INC>

b. {& A1 A % B € & INCLUDE # % -
35 /%: INCLUDE “file path+file name”
f5]4o: INCLUDE “C:\EMC\TEST\TEST456.INC”
FHRBLETETE  FTAKEERIEBE -

3 — Mz A INCLUDE #:@ %4 B H B A EE X R > Uik LR THE M -

(8) PUBLIC % EXTERN: & 4 4 #1 2 N3 2 X & £ IR KT & B A B A Project
He®iE A HAR K > #E— Project > R B4 £ oy A8+ %4 A PUBLIC &
EXTERN - 3483 5 A #9130 b 8RN3R A2 K 3R R o
PUBLIC 3:%7%: PUBLIC <label>[,<label>]

EXTERN 3%7%: EXTERN  <label>[,<label>]
PUBLIC & EXTERN T #£42 X4E{T4 7 & %4 » 47T %48 PUBLIC & EXTERN
1] 4n: 42 — 1B Project I &4 —f84% £ » TEST1.DT & TEST2.DT

TEST1.DT:
org 0x00
public  start
extern  loopl
Start: mov a,@0x02
mov 0x20,a
jmp loop1
TEST2.DT:
org 0x100

public loopl

15




extern start
Loopl: inc 0x20
jmp start
4= TEST1.DT ¥ B % START 42 4 & M 42 X /7 € & B A sh3r2 XA » @ LOOPI
B X e R B AN EXER » AL START 8% % 4 PUBLIC » M LOOPI A
€ % % EXTERN -
4= TEST2.DT R 54748 R > B 4t START /8 & & % EXTERN > # LOOPI RIZA & & %
PUBLIC -
(9) VAR: 403205 80 0 4 3 - sb % 3oy R AE R 4B 2L 2.

5% Label VAR <expression>

5] 4o test var 1
mov a,@test
test var test+1
mov a,@test

(10) MACRO, ENDM:E £ % %454
35 7% <label> MACRO <parameters>
statements
ENDM
18] 4w :
bank0  macro
bc  0x04,6
bc  0x04,7
endm
(11) MACEXIT: Bkt E #4154 > 8% MACEXIT RI#FME 4 » AR EENWIESH R
izl
8% MACEXIT
18] 4w :
Source:

test var 5

16



bank0 macro
bc 0x04,6
if test>4
macexit
endif
bc 0x04,7
endm
bank0
48 3£ 1% (AT & address)
0000 bc  0x04,6
test=5 A LA if test>4 45 A& 4F » 3B %] macexit » FF A — B 3] endm &9 A7 A 22 X
¥y Rm3FE o
(12) MESSAGE 4 output AEMTEMA L LT ETHT S -
EIE
MESSAGE “<characters>"
18] 4w :
org 0x00
message “ set bank to 0 !!”
bc 0x04,6
bc 0x04,7
@3 1% £ output R E BT
USER MESSAGE: set bank to 0!!
(13) § : BAr#2 A3t # 3 (Program counter) 4914
# S EMAEH su(operand)fE A
Rk
jmp §
jmp $§ &iE jmp B —4T 0 THEGDEMEA o

17




6. 1% X 41.3%( Conditional assembly )
(1) IF:TF ##4Xa%F B F Ao EEX9EAE > APUTIF FT—iTe92X4E > &
%]3% %] ELSEIF s, ELSE 2 ENDIF -
3B IF <expr>
<statements 1>
[ELSEIF <expr>
<statements2>]
[ELSE
<statements3>]
ENDIF
IBCH
org 0x00
bank macro num
if num==0
bc 0x04,6
bc 0x04,7
elseif num==
bs 0x04,6
bc 0x04,7
elseif num==
bc 0x04,6
bs 0x04,7
elseif num==3
bs 0x04,6
bs 0x04,7
else
message “error : bank num over max number!!!”
endif

endm

18



(2) IFE: IFE &4+ X 48.3% > fido IFE 4 @ a9 5 X 698 A% > RI3UT IFE F — 470942 X% -
7 %|#% 2| ELSEIFE 2 ELSE s, ENDIF -
35%: IFE <expr>
<statements 1>
[ELSEIFE <expr>
<statements2> |
[ELSE
<statements3>]
ENDIF
(3) IFDEF: IFDEF {41 X 423 > {8 4w IFDEF 4% @ #94% 4t (label) & € & » R34 4T IFDEF F —
T2 X 45 > H %]:®3%] ELSEIFDEF # ELSE z ENDIF -
355 IFDEF  <label>
<statements1>
[ELSEIFDEF <label>
<statements2>]
[ELSE
<statements3>]
ENDIF
18] 4o :
org 0x00
ice456 equ 456
ifdef 1ice456
bc 0x04,6
bc  0x04,7
endif
(4) IFNDEF: IFNDEF &4 5, 483% > {24 IFNDEF % @ 8942 % (label) & % % > B #h47 IFNDEF
T —47e942 %5 > & 2|:& %] ELSEIFNDEF s ELSE = ENDIF -
3575 IFNDEF <label>

<statements1>

19




[ELSEIFNDEF <label>
<statements2>]
[ELSE

<statements3>]

ENDIF

7. 4% 9 F( Reserved word )

(1) #5 5= (directives),:& B F( operators)

T - * / —
I= $ @ # (
) ! ~ % <<
>> & | A &&
[ < <= > >=
DS ELSE ELSEIF ELSEIFDEF ELSEIFE
ELSEIFNDEF END ENDIF ENDM ENDMOD
ENDP EQU EXTERN IF IFE
IFDEF IFNDEF INCLUDE MACRO MACEXIT
MODULE NOP PAGE ORG PROC
PUBLIC
(2) 454 % (instructions mnemonics)
ADD AND BC BS CALL
CLR COM COMA CONTR CONTW
DAA DEC DECA DISI DJZ
DJZA ENI INC INCA INT
IOR IOW JBC JBS JMP
1Z JZA MOV NOP OR
RET RETI RETL RLC RLCA
RRC RRCA SLEP SUB SWAP
TBL WDTC XOR

(3) # 17 % % #%( Register names)

A

20




W ~ 4k (debugger): R sk B8 IR 4 By IR 48 & B 7 R IR 48 (source level debugger)
P ds o e 22 5 B
Step '35 € PEFEE(E AT g0 FE AR VEIS » HAIUTHF A AR ERR) -
Step 2:3n 4742, » &3& T go > free run > reset > step into * step over > go to cursor °
1. 3% & F ¥7 2 (Set breakpoint)
(1)4& F  B7 8 3% 3+ $cqa (breakpoint counter): A73§ BT st #E £ 45 AT R &8 3k F Br 2
BREELTEH -
Stepl: i ##[option]—>[Debug option setting] B #8 5~ ¥} 3% & (dialog) » 3% & [Default break
point counter]| &9 (K7 1 /7 255) o
Step2: AR A5 BIakE £ P ET &Y B - R1& B B4 (double click)/F B &4 Rlg A4
— TR e stE > RETE AL RS - A4 FEB 5 X&T1 A tool bar L&) toggle
breakpoint (F &89/ 4K) » 2 4£ A menu _E[Debug] —[Toggle Breakpoint] °
(2)3% 5 W7 85 A N R
Stepl: % ##[option]—>[Debug option setting] B #8 >~ ¥} 3% & (dialog) » 3% & [Default break
point counter]&g{& % 0 °
Step2: M iR AS Bl ok A £ P B ay 4 B - R4 # B4k (double click)iF A A4 Al A4
—AB A BT R 3 H3E & (dialog) 0 IIARIA B HFE EW[OK] > A BR—ITHEH
BAk > REATETE AR -
2. $47# X (run program)
BRPIATABRAMN CFRALAGHE > UHENME > AERARFHAREZA - PRI
M 4 hot key °
(1) go(F5):4¢ B Ay 8942 X 3t 2 & (program counter) i 46 4T 2| F B 45 £ > @& P B ey A8 — 4T
RABITZE -
(2) free run(F10): # B AT 89 #2 X 3t 2 B (program counter) B 54T » 2R FT A &) P87 » H
B4 F A BOH AT -
(3) reset(F6): #47 ICE &) reset B4k » #§42 X3t 0 25 @ 2| reset &Y 414614 -
(4) step into(F7): B 5 #4T » FRPUT— 4TS REXRTH AR -
(5) step over(F8)::% 2| call 5 2 Al @ 2B & 2 X —RMAIT 2> AF|BF RET 454 A1k >
& By K e 45 4 R B 5 $47 (step into)
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(6) go to cursor(F4): #¢ B AT #4942 R 31 3 % (program counter) B 45 34T 2| B AT #5 4% Fi A2 6943
z

% -~ WICE B3N8
1. EIE /4 (Menu)

File Edit ¥iew Project Debog  Tool Option Window Help

10::% 18 (Menu)

(1) FileA$ £ R E09RE > M ERIZCIEHAIE - MEEN - BEHE - AR
B PIAS & > 2t E(Project) )R IZ &45 FABGHE ~ HAT ERMM L > FIGHE - #
HRAEMMGEERE -

(2) Edit:4%%8 % #2:Undo > Redo > ## B (Copy) > 8k _E (Paste) » 3 F (Cut) > £ F % 47(go to line) »
Find(F3%) » Replace(Bx4X) °

(3) View: & F R % R TR 4215 A & 8 F 94 E ~ Project ~ Special Register - RAM(Bank)
Output ~ Watch ~ Caller RAM ~ LCD Data -

(4) Project:3t £ & 22 #73% (new), B BL(open), &7z (save), R Bi(close), 3% o % 4% 23t £ (Add
files to project) » M &4 3t & 79 89 4% £ (Delete files from project), %1 3% —1B4% £
(Assembler file) » 48 3% K 4818 438 948 & 3£ 3% & (Build) » 23 48 3% 3 3% & (Rebuild
All) » ¥ #2 X #53% A\ ICE (Dump to ICE) » & & & & #h 47 &4 #2 R, 35 4 (Trace log) °

(5) Debug:Fréd & 32 3% & F 7 25 FFRATA F BT 86 AT X $4TH A 4% go~ free run -
step into ~ step over ~ reset ~ go to cursor ~ run from selected line ~ reset and go * reset and
free run -

(6) Tool: — B, &3 #x & ICE 32 /% 82 (Check ICE memory) > # 4% B 4% Piggy back (Piggy back
MIX format) > # 4 W %8 Piggy back (Piggy back Hi Lo format) > 3% B check sum (Get
Check sum from project) °

(7) Option: = A& & ¥2 ;3% H:(connect) » 45 2k ¥ 17 % &) B8 5~ A A& (Register view) » [ 4% 2% & (Debug
option setting), ICE code option #)3% & (ICE code option) » ¥z 3% 4 # 3% € (environment

setting) » F % 2% & (Font) °
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(8) Window: R, & HEFI% T » BFATA B RE L4 -
(9) Help:# B $R 88 iR A~ B 3 B8 & #RBE T ©
2. = A %|(Tool bar)
1 2 34 5 6 7 8 9 10 1 12 13 14 15 16 17 18 19 20 21

DR @ »[Ble] olc] Sl o 4[(C| m@2) | |
11: Tool bar
I RBP4 A & A5 5] A1) R B #%(New file)  (2)BA £& # 4% (Open file) » (3)£ 47 4% % (Save) * (4).
#2737 A A #% % (Save all) (5)F % (Find) » (6) 3 F (Cut)» (7)3# B (Copy) (8)85 L (Paste) > (9)Undo »
(10)Redo » (11)4a 3 (Assembler) - (12)4a 3% if % 4 (Build) - (13)3% ¥ 725 (Toggle break point) °

(14)Go > (15)Reset » (16)Step into > (18)Step over > (19) Go to cursor > (19)Run from selected line >

(20)Trace back » (21) Trace forth o
(MWE@DAEREEE > )E0)A%HHEEE > (11)E(12) A3t E(Project) T3 > (13) 22D AR
SR e

3. i #(connect)

Wiew Project Debug Tool Option Window Help

DielEie) a] B siel @)= o £[c] wEE <]

Connec
Micro Conit-’t__)ll;—:jr-: EM78811{ICEB11 =

Connect Port: |378H -

I” Check ICE Memory

. oK | Cancel l

Ready
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12:12 3% ICE R A[3K 1% & 3% (print port)
Micro controller: & M A\ A LA 4% 4 5 4 #% » 4o EM78456, EM78447, EM78810, EM78811 % -

Connect port: % Print port 8444t > 4o 378H, 278H, 3BCH - 3% 4% F # % 4% print port > R JA 3%
& print port %1% 483X WICE & 8 #):8]3X 3 {8 print port &9 address’ LA & #2415 B & F7 1% 3 49 print
port °

Check ICE Memory: i##:% > %43 ICE #XtRBAFTAH  UBTRACHBREE
WA o
FHig 4 ICE:i#3%[Option]>[Connect], & HRE 12 e9HZ & > ERAHTEEMIZH S L%
DEH R - TR RREEFRGOMIZH B - AR TR ICE 2 M4k
SRR R AR #y Hh 2 (protocol) &y P 28 o

4. #% £z fc(File menu)
ISICH Edit  Wiew Project De

IMews... el
rpem. .. Cirl+ O
Close

pen Project...
Zave Project
Close FProgect

A ve Cirl+3
Save As...
Save All

Erint...

Eecent Eiles >
Fecent Frojects
Ezut
13: 45 R ety iR £ IR
(1) New (#738 4% % 2 Project)

-




File | Pro]ectl

EMC Source File(#.dt ~ Add to Project

EMC Header File{.h) : ; ;
Text File(x.1xt) Project Name:test811.prj

File Name:

Location:
IC:\Program Files\EMGIEMC_WICE |

....................... 5 K T |

14: ¥IgHEE
M3 A% £ (New file): #3¥ — B EZ G L 23t E
step 1:4% A % T 1% A [Add to Project]#94& & £x(check box)sy 4% » RA %
Hu A Project >
step 2:8ENAE F 4 A% 0 f48 £ & #5(file name) sy T @A — AT 4R AR (edit) » T SENAE AT A
T ELE -
Step 3: 342 84S > fE4% £ %42 (location)#y) F @A — B #6484 45 - 45 A & TR 4 %) =18
eyl TREEMA LHHBRE -
Step 4:#% & 2 30EIA JR X 0 B TAER(OK) 4 > ATRRAMNE—EHE  REH/FA
Hr¥E A% E o 7 3 BUH (Cancel )4z -
#73% — 18 Project: #73% — 18 Project » LA B %5 — 18 3+ &) 3847 -

S8 A iE 2

Bt
S

R B

ﬁ

25



File Project |

EMC Project File(=.prj Project Name:

Location:

IC:\Program Files\sEMC\EMC_WICE |

Micro Controller:

[EM78811(ICE811) |

0K Cancel |

15:373% — B3t £

Step 1:1% ##£[Project] 49 4% 22 (tab) -

Step 2: & A3t & (Project) % #% » a3t £ % #%(Project name)#) T & A — 4T 4 2EAF (edit) > 7] 42
NEREFT AL o3t £ LA

Step 3:#B42884% > 23848 (location)#) T\ A —ERAE £ 4% > B A H TREL G =04
dal...] T REFEMA LB -

Step 4:3% 32 sb 3+ £ A7 A 894432 4] % (Micro Controller) » 45 A 3 T 47, % iB FB 4445 4 5 o

Step 5:#8 T &3 EIF MR AR > T AT (OK)#4z > RIFT R — Bt E > BAFFAE
#r3gst £ o 4R ER 4 (Cancel)#42 -

(2) Open (B BLAd & 3t & (project))
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(D I ‘A Eme_vrice

_1bin

| Jexample
_Jimages
_Jinclude

ERERA: el BEFERQ)
B8R IEMC Sonrce Files {dtsasm) ;I iy

16:BA B A% & 231 & (project)
B BLA% & 3t & (project):
Step 1::EIFEAE RIAA > 4o RIRAE(Source)dy @l 4% 4% & dt = asm > 3t Z 4% (Project) &y 3] 4% &

% prj
Step 2B ME B ER S BHABIKBEENNE  BTHAL  AHESL
HmEeRG

Step 3:4% T B AL % #%(Open) &y 442 -

(3) Close (Bfl P 4% % 2.3+ & (project))
Step 1: 1% A 7 BRI RM PO R Rt £ > % T A& A48 £EF AR G (window) -
S £ 2694 & (Active window) ©
Step 2: #%3%[File]—[Close] » B AFiE 69, % & M P -
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(4) Open Project (B Bz 3t & (project))

ZEAD: I A Eme_wice

1 bin
_Jexample

_Jimages
] 1nc1ude

EEEMEAD:  |rest8lley BIEFE (D)
IEEREMAT):  [EMC Project File (.pr) | Hyih

17: B3t &
Step L4 F i BB 4K FABLEY T & -
Step 2:4% P 7B B4 T B BB A% 6 442 -

(5) Save Project (£ 4%t & (project))
Step L4z A REBHERMFNHNE > A ENNET AN INNHEELB/AA L4
AR ENR) LI R IRFE(Source) » 2 # 4% (Reference) » List file (48344 & 4 ¢h %+
#% %) Map file(i& 4 (link) & 4 89 4 A 4Z & (Public label) &y %% #%) & ROM less Code Option
#1E e
Step 2:i% #%[File]—[Save Project] » Bl /73t Z 9 & -

(6) Close Project (B B 3t £ (project))
iE ##[File]—>[Close Project] > B B B B AT £ WICE &3t £ A, % (Project Window) °

(7) Save (£ 1748 £ .3t Z (project))
Step 1: A F B EBERBFOREIE P HTHANASE  EEFEHR G (window)
S £ 2694 & (Active window) ©

- s




Step 2: :E#[File]>[Save] » RIATERE(HE R 3T L) 4T ©
(8) Save As (5 17 #74%)

SiFHTE
B &S0 I 3 Eme_wice
_1Bin =] test4 56,1
1 Images _@ tastd 56, pry
[ Include #]testd 1 1.cds
] test] dt #]test211.deg
= TEST1.Ist 2 test3 11, prj
> TESTL.obji =] test820, pri
%] testd 50, prj #] Uninst.isu
fEECEW: | FATFIEED
FEEAEEY T IText Files (¥ %) ;] BT
I BEERMERETE(R)

18: 7 17 #7144
Step 1: A F RBFREFOBE > BT FRY L4 > E:EIFHA T (Window) > 8 R
* 894 % (Active window) °
Step 2: #E##[File]>[Save As...] > Bl €88~ 15 B Mg HEE -
Step 3: AN E LM HELBNGBBERMAEHZENEELB]NEE -
Step 4: & B B Ak T[4 7418 Bevdkdn I BN EGRGF MERCEANGEE -

(9) Save All (i 77 B AT SR B &Y AT A 4 £ R 3T E)
# #[File]—>[Save All]

(10) Print (3] Ep)
FIEp B ATATEFE W RBARE

(11) Print Setup (Ep & #32% %)

(12) Resent Files (F i1 B B 89 4% %)

(13) Recent Projects (s 3L # Bl 893t %)

(14) Exit(# )
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5. % %8 3} 4t (Edit menu)

[0 View  Progect  [Debug

LUnde Ctrl+Z
Eedo Ctrl+A
(Cut Cirl+3
Copy Crl 4+
Easte (ol -
Clear Liel
=plect ALL

(3o to line ...

Find... Cirl+F
Eeplace...

19: 4 8 2/ AE

(1)Undo: =1 48 AT — 18 4 48 ) 1F
(2)Redo: =148 Undo & A7 — 1B EH4F -

G)Cut:H T > #H4mBEALE R G &9 STFRIR o
4)Copy:# B » #H4hERENREGVXFHA -

(5)Paste: B b > H§ AT — B H R 09 X FRE A AR AT B 30T ©

(6)Clear:iF 4 o
(7)Select All:3E 42 4884 % W 69 P A XF °

(8)Go to line: 4§ #5142 #% B 45 A P iy A 94T 8L o
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Line: Im

OK Cancel |

20: 80 NI AL By B9 AT L
Step 1:#y AATEL ©
Step 2:32[OK 4% 4z -
(9)Find: 3% A% F & AT 8T N B9 LT o

AE3|
SHREEW:  [nov PRT—{EE)

r 2EHEEFacn AR e
rAuEmEae | CRED FHTO

2L FHF B
Step 'Ew AR F R F S -
Step 2:EHERZEHNF » KANBEFEG  HALIBATFHK -
Step 3:3%4% T — 18 (Find next) &4 3 4z -
(10) Replace: F 4% 3 BAXAE A 4 A7 F 4% BB B SLF o

smEgw: [ il
EHEREEE: HYH(ER)

e
RS %”@mm
r RUNEEREQ il

22:FHRIERKRT B

31



Step LBy AR FHG T & -

Step 2 ANBRZ T & o

Step 3:BHE R EHNFRIRNINEEHRE -
Step 4:3%4% T — 18 (Find next) &4 3% 4z -
Step 5:4% B 4%, (Replace) 24z -

6. B3 ~3h%e(View menu)

Froject  Debu

Froject

~pecial register
EAM (Bank)
Ctput

Watch

Caller EAM
LCD Data

23:View #&4:£318
(1)Project: w3t £ A% (Project window) » 3t ER & + .45 Files(RIR1E > 814§ % & DT
#2 ASM) - References(%# 4% » R BA4E ¥ 19 INCLUDE M #94§ %) » List files(423%4% &
AR E > BB ERBIEHA —@ LIST ¥ £ > 244 4 LST) > Map files(i& &%
AL E > — 18 Project A4 —18 MAP #% > WA X% A /)% %K (Public label)sy
ik o
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E-@ File

=& Map Files
2 CProgram Files\EMCOEMT WICEMestd 11 map

24:Project R, %
a. ¥ ho g% & 33t Z (Project): & ##[File] >[New...] # ¥ 35 614 352 #E[File|2 & -
HLBAE R ARG I -
b. 3 v —18 R % 18 € 448 69 4% & 2] 3+ £ (Project): % 3%[Project]—[Add files to project] °
HRHFE SR > FEFE—ARSEEE  FLRA T ER I -
c. MR EFHREAFTABIKRIBNEE B THALSE  FREZENHERS
% o ¥eéEMkey Del g2 AT ERBELBORGANITEF -
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(2)Special register: B~ R Y F R WA E > @45 & v B (Accumulator) > 4% #] % 77 5
(Control) » #5535 0 2% 5% IF -

LI

BO_2X:
BO_3X:
B1_2X:
B1_3X:
B2_2X:
B2 3¥:
B3_2X:
B3_3¥:

0

0o
0B
olo}
0B
0B
oo}
o]}
olo)

%; ReGs and [/0s Window

ACC
R1©
R11
R12
R13
R14
R15%
R1&
R1T
R18
R19
R1A
R1B
R1C
R1D
R1E
R1F

<

00

00 R4
00 RS
:00 RE:
:00 RY:
00 RS
00 R9:
00 EA:
00 RE:
00 RC:
00 RD:
00 EE:

RF :

:00 CONT:00

00 RA(A.U) 00,00
00 R1/TCC:00
00 RZ/PC:0000
00 R3:

alefolalalafe]s)
TES43210
ejolalelojalelo
C5:00
C6:00
C7:00
C2:.00
C9:00
CA:00
CE:00
CcC:e0
cCD:00
CE:B0
CF:00

e]o)
00
00
e]o)
0o
B
P
B
(o]0
(o]
]

Pagel

CB
cc
cD
CE

00
00
00
00

B

25:Special register %, %

CHBRBEMEAT BB EHERERNYFTE > £ A 16 &k AIEEEA
0~9 » A~F » 2 & 2 fr R {24530 A 0 Fv 1 » H AR R A8 A H back space & Del 434 R
RetER > BREX—EET > AR RRICEHHFEHNE -
(3)RAM(Bank): # 5= RAM(BANK)— # % 7 S5 -

1 2 3 4 5 6 7 8 9 A B C D
00 00 BO-00
08 00 BR-00
00 00 BB-00
00 00 BO-00
08 00 BR-00
00 00 BO-00
00 00 BR-00
00 0O 0R-0O

o]0]
o]0]
o]0]
o]0]
o]0]
o]0]
o]0]
o]o]

0e
0B
olo}
0e
0B
olo}
0B
olo)

00-00
00-00
00-00
00-00
00-00
00-00
00-00
00-00

o]
o]]
o]]
o]
o]]
o]
o]]
ole)

o]0]
o]0]
o]0]
o]0]
o]0]
o]0]
o]0]
o]o]

00-00 00
0B-00 00
00-00 08
00-00 00
0B-00 00
00-00 00
00-00 0B
00-00 00

26:RAM(Bank)— £ % 17 B %
UV BGEUT Ao BFHREFEHELT X -
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(4)Output: Za-~ —AZM B8 » hofAE ~ 48R » 2 X % HaT:8 89 2 X #5(trace log) »
% Output REARLHERFAM > AMERAEERAFRARLE L AR AL EY
(Double click) » R#54% B B ¥ JE 2] R RAZ ©
(5)Watch : B~ A5 & RS HONE, S5 Mnt R ME. 4w B Fig 27.
mEIE
R20 OOH Bank(©®) ADDR=20H

R21 BOH Bank(®) ADDR=21H
R22 0OGH Bank(®) ADDR=22H

« _ ]
B 27:Watch %
(6)Caller RAM: 3 % /% #2 %2 4 CALLER ID RAM - R|# Caller RAM ¢4 B8~ .% » BAT#
X 4o RAM -
YR BHEEAF Ko BHRYFRZNELTA -
(7)LCD Data: % #4& ¥ % 4 LCD RAM » B|4 LCD THBETHRE °

| Update l El COM=0{00H) , SEG=0( 0OH) ,Bit:=0
nnnR OOH DATA=18H
15 20 25 30 35 49 45 50 55

B

Bl 28:LCD & HARLE
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LCD %
FEG R~ 1 &EEE K5+ 00 COM: &>~ common 1E » SEG: % 5~ segment {8 > Bit: %k
= &k A # % Bit 0 ADDR:#% 5+ LCD data address » DATA: % 5= LCD data &9 N % -
WyEAe:
a. Update:f5 2L B4 » ¥ Update #5242 > Q| € # B R FEAICE F
b. LigRey e AL LA -
c. REZREEILALETA -
%2 LCD F#F Ko
RSB Gl TR RAASE  RIARCOHREL  BHACTY AR
& LMARTRTE0 041

7. 3t & zh ke (Project menu)

Debug  Tool Option  Window
Iewr...
Crpen...

Save

Closa

Add files to project...
Delete files from project...

Agzemble file

BEuild Fa
Eebuild All Alt+F9
Dump to [CE F3
Trace log F2

29: Project h Ae &
(1) New: 373 — {8 % & 4493t & (Project) ° 4o [ 30.
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MNew project

Project Name:

tesiB11

Location:

CAProgram FilesS\EMCGIEMC_WICE |

Micro Controller:

EM78811(1CE811) ~|

Ok Cancel |

30: ¥ —1fEztE
(2) Open:#7 B — 18 €. 77 1 89 3+ & (Project) © .
(3) Save:f# 17 — 183 & (Project) °
(4) Close: Bl B] — 183+ & (Project) °
(5) Add files to project: 3§ 4u % #§ & 2|3+ & F (Project) > A 248 K T4 > AT A 4t

HReHF — B R % 18 % 4% £ — R v A3t E (Project)
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TR I A Emc_wice

_1Bin
1 Images
1 Include

EEEZEOD:  ['testd56.dt" "test].dt" oK
e =R T ;EMC mource Files {dt;asm) ;I H

31: AfuA %18 % #% %] Project
(6) Delete files from project: MR EZ PE4EE > W E 32 -

Delete files from project

CAPROGRAM FILES\EMCAEMC_WICEATEST1.DT
CAPROGRAM FILES\EMCAEMC_WICEATEST1.LST

CAPROGRAM FILES\EMGAEMC_WICEATESTB11.MAP

 Delete files from project | Exit |

32: MR EFTHRE

(7) Assembler file: 43245 £ - A B AT BN GBI E X AB R T~4£ Output 5 »
A EeER e 0E453R 0 0 BEL -

(8) Build:4a 33t i 545 % > @3 Project PR ARG @ F XA FRIORBAE > 4@
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FERBS A AL EIE - @EM RN AT Output A%

(9) Rebuild All: #8377 A R R4S » R KRB AT §E@F0 0 S HFRE AR R
VEid & B 4F o 4B 3% vl 4520 & BAT 4 Output % ©

(10) Dump to ICE: ## XA ICE g9 X2 e8 ¥ - & 3 E 33 H A ¥ (Dumping)
WHE > BEHNRBATR > AFEMMKERLRE -

Dumping

Dumping ....

. Cancel

33:# A ¥ (Dumping)
(11) Trace log:3h4T trace log #9854 » R A £ #MATH X A Go ~ Free run ~ Go to cursor &
step over (& %] call 354 8%) > 4 €48 Output A% B R AIITBNIES » FBEK S
B~ K 9 & o

8. 2423 se(Debug menu)
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Tool ©Option  3Window  He

E=
Eree Eun Fl0
Reset F&
Step Into F7
Step Over Ez
3o To Cursor F4
Continue step into Alt+FEY

Eun from selected line

Togele Breakpoint

Show all breakpoints

Add label to watch

Eezet And Free run Alt+F10
Eeszet And Go Alt+FS

Eun froem

Address Break point A+ A

Clear all breakpoints
Clear watch

Trace Back
Trace Forth

B 34: iRéEh
REHEERZRTERFEERIT T E% >
RGHEFREA AT REREES
(1)Go(F5):F5 & #42(Hot key) » Go #9347 H A 24 B AT 8942 A 31 2 B (Program Counter)
—EPUTEIPETE A /L - PETAL—AT8946 2 € PUT R 24P L AT ©
(2)Free run(F10):34T 7 X &4 B BT &9 42 R 3+ 3 & (Program Counter)— & #4T 2[4 A & 3%
B 35 4% L AT HY[OK 3k da 0k > Be& P A SR T 89 F B -

AE
YRRy WICE €% 4

R
wE

% Stop Running

3545 AT
B 35 AHATH RN B HROELA -
(3)Reset(F6):ICE E#3% & » —&BFHYFEH B R R RAETIRGME - of2 X3 H
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% = 3] 25(0 5 ROM size 5x 1% 6948 hE A% 41 35 09 LA ) o

(4)Step into(F7): 85 #47 » ICE # @#UTR AR B aIEL  JUT TS BIRLL
AT o

(5)Step over(F8): 2 Xt # K Ariaeyd6 25 A Call RIFUTRE B X F17.L > ZAH
Cie o Al BHPIT 0 —RBUT—THL -

(6)Go to cursor(F4):# #2 X3+ B B B4E AT B AT AR AT RO B > B8 PR TR T8
P 7S o

(7)Continue step into(Alt+F7):i& 4& 34T £ 25 $94k (step into), & 2| IR H #AT °

(8)Run from selected line: 4% M 4 i% 4% 12 18 ) AE 1%, B F RIAAT 69 A2 25 B 3543 AT 42 64 12
% o

(9) Toggle breakpoint:3% & F i » 3% & ¥ Ef 5 X 7T A TR F 8 ¥ 893% T T B L -

(10) Show all breakpoints: 4 output L%, #-TATA P B 52X T &9 Bk

(11) Add label to watch: 4% Watch 8%, 3o MR 2 > k@ 35 -

Add label to watch

File name:
—
4 | I »
=R20
=R21

Label name: [#R22

—Kind of label
« Special Register{R0..R1F)

© Control Register Page num:
~ RAM(Bank) Bank num:
~ Gall ID R&AM Block num: | -

chad

Add to watch | Delete from watch | 0K |

36:3% Au label ] Watch 2 %

(12) Reset and Free run: ICE & #73% & it #i4T Free run -
(13) Reset and Go: ICE & #73% & i #4T Go o
(14) Run fromEEHATH X > BHITRBAGEREZAFITIELS R LH I XRE > 24
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i o

Initial writh 28K -Step log
Corrent PC owith 8K -Step log FS
Initial writh 4E-4K log
Current FC with 4K -Step log
3T HEHATH A

a. Initial with 8K Step log:#¢ #2 X R BB W FAT A PEIE A AL > TR FETE A ZATHY
8K #hiTidayd5 2 Eokt -

b. Current PC with 8K Step log:#% B AT 2 X 3T E BB #IT » AR TETEA AL > FR T
BAs A 2 AT 6 8K $UAT@HIE L B At -
. Initial with 4K-4K log: 4 2 X B 25 46 $0T B 5 ¥ Wi g5 & 1% > BT 4K 354 B 1k -
TR B3 A Z AT R 215 & AK 4T 8B a4 2 B o
d. Current PC with 4K-4K log:#¢ B AT#2 X3t 8 S M4 #4T > B2 P EE A% - BI4T 4K
EA A FRPETRAZATRZE L AK SUTB L B A

(15) Address break point: 1% Fl B4R X P Ei ALk o935 & P B H 7% > 4o 8 38 o
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Address break point

" Address breakpoint not active
" Breakpoint group

* Breakpoint or

 Breakpoint nest

(0X0001 0:X0003.0X03)(0X0004 0:X0005.0X06)

L« | ||

{0X0001 0x0003,0X03)(0:X0004 0X0005,0X0b]
{0X0001 0x0002,0X01){0X0003 0X0004,0X01)

J | 2

OK Delete string from list | Cancel |

Breakpoint or and Breakpoint nest syntax:
(OxAAAA 0xAAAA 0xXPP) (0XAAAA 0XAAAA .. 0xPP)...
(Address Address.... Counter){Address Address...,Counter)...
Breakpoint group syntax:
{0xLLLL 0xHHHH,0xPP) (0XLLLL 0XHHHH,0xPF}...
{Low_address High_Address, Counter)...

38:3% R Ak ¥ KT

EiHEEER G PE 7 XA address PET, BARBRE LAEBEXAFEH IARALRF

8y, AL L E A address P BT, A RIR P BT & &k, B bk #E#Address breakpoint not

active”, R RRFEFH XA FHER.

Address ¥ #7 & & =4, Group, OR, Nest, 3% & f.f OR ¥ Nest 49% £3E % —45, A

# Group #93% £3E XK.

(a) Group ¥ % 63 18 group, 518 Group A AL45 bk, Kk AL bk R R 3, % K AL 45
BB AL BE Y AR AT AL WL AR BAT B, REOR 1, B REEN 0, Al PEE A, M E
518 Group & Z ABJE 3L &Y.

(b) OR ¥ i7: & % A 63 18 group, 418 Group A %A at B — 1At # %, % Group N
BAEAT AL A AT R RIS RO R R 1, B3t BB %N 0 85, Bl P e 4, ™ B8
Group & Z #8%4% 3L

(c) BARKX VB ERX ¥ BT APTAH X TH Group 18 A1 3Ltk BT A 45 4A - 53%

2 £k X ¥ #F Groupl, Group2, Group3, B|%E Group3 w4t %E» 0 1%, BEH
=
i)

Group2 93t %% 0> B%4 Groupl 893+ A 0 > Bl PHi A 284, RILERE
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ShE &9 Group 93t HE 7 0 4%, KPR RINE Z RN B HTEA 0 8 > Al ¢
Bt A -

Bldo: T KA F B

Step 1: # 3% Breakpoint nest o

Step 2: 8y A\ ¥ B ik 0 3% 8 A(0x03 , 0x01) (0x05 ,0x02) » A (0x03) % group A » ¥ &f
FEC1 R(P BT SR TR KRB R P A ak & R A A P B > (0x05)% group B> &
st # 2 K e

Step 3:4%[OK 442 °

Step 4: 34T Go(F5)45 % -

Step S: 5 /F £k X PB4 > PETE A E & group B P Ei& 4446 0 K42 F4F group A
TER MR eR > T e R A TE > —RERKXTETAN RS FETREKX -

9. T A 3zj%E(Tool menu)

Option Window  Help

Check ICE memory

Firegy back MIX format
Figgv back Hi Lo format
(et checlsum from project

(Clear all output mapping line

39: T B A
(1) Check ICE memory:#: & ICE #2 X218 £ T A -
(2) Piggy back MIX format: & 4 ¥ %8 Piggy back 4§ MIX # R, » 2@ #»#4% EEPROM 2 A o
(3) Piggy back Hi Lo format: & 4 R FaA #& &) Piggy back & High & Low &9 R, » keé%k
EEPROM z A -
(4) Get checksum from project: 3+ & 32 18 3+ & (Project) #3 check sum - LA f® # F Ordering form
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Z R e
(5) Clear all output mapping line: 7 F& Output 2, % ¥ /& 2| R R4% R & &9 Fets o

10. #FF M &3 4E(Option menu)
it Window  Help

Connect

Eegister view
Debug option setting
ICE code option
Environment setting

Font...
40: £#% M 5 #E(Option)
(1)Connect: & #7:& # %78 ICE » T %88 WICE 3% 3% 1) 43 4 1% 4 (connect) 7 4
(2)Register view: 3% 5€ 45 2k % 17 %5 BT 09 AV AR (N i A 3 — i fxr) o

CONT: ™ Binary Type

R3: & Binary Type RA: I™ Binary Type
R4: & Binary Type RB: ™ Binary Type
R3: ™ Binary Type RC: ™ Binary Type
Rb: ™ Binary Type RD: ™ Binary Type
R7: ™ Binary Type RE: I Binary Type
R8: ™ Binary Type RF: I Binary Type
R9: ™ Binary Type

Default view is Hex type

0K Cancel

45




4145 5 %545 % o7 A6 3 % (Register View)

Ho ] 3% :

Step 1R Awsk3k L ¥ 17 5 A = 88w » R A IF & 45 240 & & (Check box) L » # F i &
g B RBITASE A6 T AIETFTRE -

Step 2:3#% T [OK]#%4z » A4z Y77 B 9B~ o (L A E P ey RV AE -

(3) Debug Option setting: (444 Zh fE 3% € °

Diebug setting

v EDumping codes and checking§

™ Interrupt disable after break point.

Default Break point counter
Default break point counter{0-253): |1

If default value 0 then show counter dialog else not.

™ Show source code in trace log

OK Cancel

42: PREETHRERE

FESAWNE:

a. Dumping codes and checking: % 3£k 5 £2 K B H{ N ICE 85 > £ FAR B2 KB {NLE -

b. Interrupt disable after break point: 42 P4 4% ¥ By 2545 £ 14 P % ICE 89 A + BrBA B - Bil B4R
FALIT B F BT AR © PR IR A2 A B AE F BT 0 4 A7 TCC » COUNTERI » COUNTER2
TR AKX - MRS P BT A AT TCC » COUNTERI] » COUNTER?2 3448 & % :E4F » AT
1 A ARIAHAE > B R & TCC » COUNTERI » COUNTER2 i R & R4 PB4 1% - %
fFak > Bk g mlrid S0 E % -

c. Default break point counter: Fazx P B3t 30 5 > HhAEE L RIRSE R T PHIZ F & -

d. Show source code in trace log: Trace log &) 24 output R E N, TAX AT RAFN N
%, PUTRE B 2 RIERM AR trace log Arak B R IRKE 69 4L hk P72 89 FR — 4T
N2 B84 Output A%, MHMRE &R -
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(4)ICE Code option: ROM less &y o AeiE 7R » X4 B A RE &) AeE IR - HE &4k
SRR T GOR PR BB AR 0 ER AR A RRIE S B - o 43 -

Oscillator: ~ RC
Clock: = 2 4
Target board power: © Using ICE & Self
Type: © A(28 Pins) & B(32 Pins)
Watchdog: # Enable  Disable
Frequency: & Hij Lo
OK Cancel

43: ICE code option

(5)Environment setting: 3z 3% 3% & © 4o g 44 o
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Environment setting

W Create List file

[ Create MAPF file

Editor window contains: {10«
Recent file list contains: |5 v
Recent project list contains: |4
OK Cancel

B 44: FILKE

a. Create List file:40 22 RBIE14 A F A4 LISTH L > LISTHZ X 6035 T4T8 > sk o
RABRERFAZA -

b. Create MAP file:i# 1% & 4t MAP 4 % » £ 219 % % 2 A% & (public label)sy fr 4t -
2 & H L2H -

c. Editor window contains: 35 WICE &4 #k #8 $h4T B 48 ] B Bl BL A9 SR 8B4 2L E » R % 20 1B 4
$EAE

d. Recent file list contains: 45 [File]>[Recent files] N A5k 0948 £ % > & % 10 18 -

e. Recent project list contains: 35 [File]—[Recent Project] ™ A 22 4% 893+ & (project) i@ 2t » & %
10 18 -

(6) Font: A » ST AR T h B RIBFHR G FRZR—RYGFRZNFTA » AT A 4hiE4g 5 Output
REAR—RFA > mERYEEL—RYGETHNEELFH  ERRAEFELFH -

11. 4% % (Window)
BSREHIN T AR BATHAMHRE L4 -
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12. £ 8h(Help)
(1) Help #% 3t & % A WICE #2 & ¥ » {25 sA 347 [ B 4] —[#2 & %] -[EMC WICE] —[EMC
WICE ReadMe] > Read Me # %4 HTML ¥R, > FrAE A HZ TN R 2 A EI T SBPT
3% -

(2) About: B A R sk B2 ey bR A » WWW FER B R T F1z 02 X%t K8 -
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7N ~ 45 3% 31 8 (error message)
BRMEERS AW M BAETRAPUTIE LR A BAEFrg 4 e
BAE G A 08E3R D B ATREEET A A 0y 43R -
LM #: £ APATe8%
(1) "error M0O1: Numbers of opening editor window are the limit !!"
BRRHEREHE CRBBRG  BUEARAELKERE °
HERR B R A RERE M -
(2) "error M002:Not enough memory to allocate Editor Window!!"
P RARFEIERRELEBERE
Bt BU R R ANGEREHE M AKR LG ECEREZRN -
(3) “error M003:File: [filename] is existed.”
BH:GEBECHALE  FEEALCEHEELBNHEER -
Hey L B R LB BRIE 0 BA -
(4) "error M004:File: [filename] can not be created."
BH (248 oRRARXSBEEREEL -
HRREXLERERT » ARFBEIRTHEF -
(5) "error M005:0One project has been opened!!"
B E R EECH—18 Project 37 B » B bR FE A 47 B B — 89 Project ©
HEFR ¢ LB B €47 B &Y Project © H47 B 48 4% A &9 Project ©
(6) "error M006:Project: [filename] can not be created."
B R AF¥E A %iB 4o JE A 42 X 3518 Project RA & & 0 34 A By Project 89 % %% o
HR MBI EHELBRAAGN  BEHT > ARTBERTES -
(7) "error M007:The file [filename] already exists in the project."”
BB A R & Project I o
HerR 1 R B Ae B R 8948 & B Project A e
(8) "error M0O08:File: [filename] can not be saved !!"
¥ Al AR SEE R AR -
HER AR ERBHELBMAAMAN > BERT > ARFBERTHF -
(9) "error M009:The project: [filename] is not EMC project file format."
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J& B 48 Project A & WICE Ff#, € 89 Project 4% =R, °

HEFR ¢ MR 248 Project » B & 4 —1A#7 8y Project » KRB IWAR RIER » B o

(10) "error M010:The file: [filename] does not exist."
BE i i4@8oRRARXSBEERTFE -
HrREEEREREFARTHESE -

(11) "error MO11:The File: [filename] can not be opened."
BB ARE RSl ko B A AR A A ERAEITH
HpREEEREREFARTHESE -

(12) "error M012:The file: [filename] exceeds %dk of the max size %dk."

BEGEEENRECRBBERATEERAMARNK D > BATHBREEEENTR

TREA IM -
Bk D RS AEINER SR RE -
(13) "error M013:The copy size: %d exceed %dk of the max size %dk."
BREHANKERBRRGKE
HER D BE RGN B R HER -
(14) "error M014:Memory can not be allocated."
BE D RGEERABITIERREA -
Bk RS RANGEREGHE  XMMHAAKRLOECTEARZN -
(15) "error M015:Over 250 characters of a line !!"
BE AR ATHX T %hE 0 LABE 250 B F -
HeW BT TG %R
(16) "error M016:The active file [filename] extension name is not .dt or .asm."
BB aFRIRAEE 8IS L A A DT & ASM -
PR 8148 % B ” DT & ASM -
(17) "error M017:No file to assembler."
BB RAAEE T EE -
Bkt BEBEERETE RAFORX > BIUTEFE -
(18) "error M0O18:Project file must be created."
JRB sk F AT B Project © A REAF4sERIE L o
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HEFR ¢ 4T B RT3 — 18 Project ©
(19) "error M019:The editor number is over the max editor number."
FHE BT B CRBBRARNHE -
HeMR R EER A ey AL G BB o
(20) "Error M020:No active editor window."
J7 B : Editor L% B AT AMER -
PR ¢ IR Bditor R E -
(21) "Error M021: Text field must be input characters."
BH D XFWMAMAREZG ©
HEIR D BT o

2.A MR WmERR AR

(1) "error A0O1: Can not find the [filename] file"

BRE iR SEAEERTFL -
R RECEREREFARTHF -

(2) "error A002:main and subroutine program can not define [label name] local
BB BRAEMZEMASEAENZB sz 2K -
B OB B R AR B A 2 EBAAR K

(3) "error A003: The syntax form should be: operation [operand][,operand]"
BB FEEEFE > B E B operation [operand][,operand] °
HER AR BRI > EM4RE -

(4) "error A004:The label [label name] is redefined."

BB EERRERTRK -
Py EMTBRRRELHE -
(5) "error A0O5: The EQU syntax is: label EQU operand"
WEY TR EQU M2 5 &
Bt FEAE R P EQUAE R -

(6) "error A006: The INCLUDE nest deep is over 256."

B H : {# A INCLUDE &9/R & e.#2i% 256 R(INCLUDE W A INCLUDE) -
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HERR ¢ 242 X W INCLUDE 8975 X, » R B/ 7 256 R -

(7) "error AOO7: The IF conditional expression is error."
BB CIF ey EL XA -
HER  EH 4R TF a9 ik g AKX -

(8) "error A0O8: Attempt to divide by zero."
BHEREXFHEABRUNOGES -
HebR  EMSBEE KX -

(9) "error A009:The assembler dose not support floating point."
BB RE@ERERh REFREL -
HER C BIRIFREE  BOAERES -

(10) "error A010:The symbol [symbol name] is not defined."
BR: EEZEEAATE -
P R REERK -

(11) "error AO11: The macro name [macro name] is redefined."
BR:EEEEEFRLE -
Pk EMTRER LA

(12) "error A012:The parameters name [parameter name] is the same as label."
BRI ZBLBERELBMAE -
P EM TR SFBALAE

(13) "error A013:The parameter name [parameter name] is the same with another one."
BH A HLBAF—EERROELCEHLMEAE -
Pk EM RSB ALAE

(14) "error A014:The number of actual parameter dose not match with formal parameter."
FR EERZRENFIHBEBARTEENSEHARS -
HR SR EEPATH S A -

(15) "error A015:The parameter number %d does not exist."
BH:ZELEMELLAA TR -
B SR EEHUTH S 3 -

(16) "error A016:The external symbol [symbol name] is the same name as defined label."
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BRI RGBEAEENS T RIBE 4 -
HERR ¢ EME RAE R NI AR
(17) "error AO17: Address of ORG is error."
BB : ORG firht & & % 4% °
B ¢ EH LR ORG fiik ©
(18) "error AO18:MACEXIT can not be set outside macro."
B : MACEXIT 7 4642 MACRO M oh 377 & &
gk # R MACEXIT -
(19) "error A019: Parameter must be string variable."
RHE 2 ELBARTEEH
PR KL BYBRERATEEE
(20) "error A020:Memory can not be allocated."
BH A& EkREESCEBERER -
HER B ERTANGREREG M > MMAKR L ECREARZK -
(21) "error A021:The source statements exceed %d lines."
BB RIRAE 64T AR B R
Herr C R A B -
(22) "error A022:The tree is error because of parser error."
FRE D E—ATHBIEA S
Hebr  EMBETE TR -
(23) "error A023:[allocate memory type] memory fault when allocated memory."
BH A EEREESNTEBERER -
Bt B YRR AGEREHE MM AKRLOECEREZRN -
(24) "error A024:Set assembler variable must be integer value."
BB ¢ o4aiERF 4 # (VAR operation)g) A EE XYL RB A KLH -
B R A SEERX -
(25) "error A025:Address of ORG must be integer value."
RE : ORG T & ey ik R A2 K8 -
B ¢ EH LR ORG fiik ©
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(26) "error A026:The %d address of PC is out of %d ROM size."
FHR A EHNECLEBEROM g kE > #XB/RKE °
ek R RD -
(27) "error A027: The assembler is exceed max pass %d."
FB RS REABBRA ) Z TR -
iR mERARFTARCRVEERRE > RESFREKR -

(28) "error A028:The operand %d value is not including the valid data. "
BH ZEELANEIERESTEGME -

B ERERATHEREX -

(29) "error A029:The %4X address is conflicted."
BRERXBGMAEEER > AR RERBME 4 -
Bk © & A [Edit]>[Find]4e LIST 4§ % © F 3k 2Bk > K42 A 2] ROFAG 5 202 ALk

(30) "error A030:The file [file name] could not be opened."

BR ¥ p@rERARXSEEEREITH -
Hp  mESERBERTHAXRTHEF
(31) "error A031:The configure file read error."
BB O ARAIE S S R AR R AR o
Pk EHE K WICE -

(32) "error A032: The file [file name] can not be opened."
BH (i 4a@rRRARXSEEEREITH -
R REZERERTHFERTHFFE -

(33) "error A033:The macro is not defined."
BR:ZEEEAARLR
P RRMHESR  RIEREELHS -

(34) "error A034:The expression can not be calculated."

BB EEERXEKNHE -
Py EREREREZNX -
(35) "error A035:The operation [operation name] is not defined."

RE:EEERFEEATRK -
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HER B EER T LA -
(36) "error A036:The PUBLIC or EXTERN label [label name] must be address label."
BB REFNA R E R LIFRMAATE
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HEPR AR B N RGBT AR -
(37)"error A037:The operand value can not be calculated."
BRE EEEE B ERAETE -
B S REE TN ERRX -
(37) "error A038:The symbol [symbol name] is not extern symbol."
BH BERKERTIFERGREK -
HERR © EHE K EEAZ MK EXTERN g5 4 % % &
(38) "error A039:The reference number is over %d limits ."
7 B : PUBLIC 2 EXTERN 7% ¢44% 4 # B A28 & K {4 -
BEM © % EXTERN 8942 8 547 4 35 -
(39) "error A040:The length of file name [file name] exceeds 256."
BB SR L AEARE 256 R -
PR AR LB R R B -

3.L#: R4S -
(1) "error LOO1: Memory of [memory type] stack overflow."
BE D RGEERABITIERRIEA -
Bk RS RANGEREGHE  XMMHAAKRLOECTEAREZN -
(2) "error L002:The [file name] not found."
BB AR RSl ko B A AR X EEAEERAEITH
HrREEEREREFARTHEFE -
(3) "error LO03:The Object file format dose not belong to EMC object file format."
B : Object 1% % K& WICE i & R a9#6 R -
BER D EHEEZERRKE -
(4) "error LO04:Symbol [symbol name] is not defined."
BB EERKAR TR -
Py P T REEREK
(5) "error LOOS5:Public symbol [symbol name] is conflict."
B ERE AN AR L
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B EM R REEARBLAE -
(6) "error LO06:ROM address %X is conflict."
BE:RXBHGMAEEER > AR RERBMLE 4 -
HErg ¢ EFE([Edit]>[Find] 42 LIST 44 % + F ik S B at - K 1% B 2] RIRAE S B0 Ak o
(7) "error LO07:The file [file name] can not be created."
BR ¥ rspdoERARXS@EEREEL
HER CARERERHENT > ARTBERTHF -
(8) "error LOO8:Line %d: The machine address %X exceeds ROM size %X."
FH A magEcB8EBROM g kE > B/ REk -
B R AR -
(9) "error LO09:No project file active."
J7 B &K Project TFA o
PERR - B BL— 18 Project °
(10) "error LO10:No output window found."
JZ B Output % 2 A BAL °
HErg © E3E[View]—[Output] » A& H 3R, Output A% ° F R 3Fi@ sof2 K& :t6p -

4.D #: FREBETE A QSR o
(1) "error DO01:The ICE memory is error ."
BB :ICE seie g8 A 53R -
B 0 R ICE #hzeie gl » G RER -
(2) "error D002:CDS size=%XH does not match the ROM size=%XH."
BH :CDS ¢y Xk E ¥ ROM 2 Rk EF — 1k
Pk T EM AR 0 & ICE 094384k A & £ WICE B35l B 096K F -
(3) "error D003:The project MCU type %s does not match %s ICE."
B E & (Project) A& ey s d b B (BTN 3t £ AL % e936 3A(Title))#2 WICE Fr 1% a4 42 4
% 4B 7 WICE 48 % 4936 34 (Title)) R 74 &
HErp T EA MG E RS WICE #8488 — 34 8 -

(4) "error D004:The line of file dose not transfer to machine address."
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DORRAE 0938 — AT IR A B R ARARAS o
Bk R ERBARGHET A HHR -
(5) "error D005:The break point group number is over 64 ."

BB kR PETEE AR AR 64 18 > o R A E A RIRAS X BT > Kom PETEAZS 64

18 -
PR D BRSBTS

(6) "error D006:The ICE is not connected to PC."

B H :ICE 3% A% 4 PC-
Hey L F SRR A e

(7) "error DO07:The Printer port is not connected."

BB EPRIBRA R -
HER C A BPAMI S o

(8) "error DO08:The number is invalid."
BB BMARGeHREGRT -
HEFR C EMBAS RO BT -

(9) "error D0O09:The number of messages is over %d."
B E 42 Output L% P& E B BB AME °
HER R TR HME 0 do message F5 4 ©

(10) "Warning D010:The address %04 X does not match source file."
BB A2 KGOS e ak Bk HE R RORME -
HER D H LRI o

(11) "Warning DO11:Memory checked is error !!"

B H : #E ICE nlafs A 445 o
HeWR | H LB
(12) "error DO12:Syntax error!!!"
B BIREER -
Herr C EEBRAAF S ENERN -
(16)"error DO13:Memory address %08X is error !!!"
BB B REA E A
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PR ¢ B4 ICE e fef - RISRER -

(17)"error DO14:Cann't found breakpoint address of %s."
BB R RIRAG P e Ty 0 R AR Ak
PR © AR T BT o

(18)"error DO15:The number of symbols is over %d.”
BB ARRE B ARBRA
Hebr DB RBEESRBBEREZHHE -

(19)"error DO16:Please dump program before adding label to watch."
J& A : 4% A [Debug]—[Add label to watch]8%, 3% st 3 47[Project] —[Dump to ICE] -
HEFR 1 34T [Project] »>[Dump to ICE] s i%zhAc42 F3 -

(20)"error DO17:Trace log is empty "

J& B : Trace log P& F EH o

HERR e T AT Go, Free run & Go to cursor 4 A trace log o
(21)"error DO18:No trace item in trace log. "

J7 B : A trace log MIXREBIAFZHEH -

HER  FPUT AL

* F AR R (Q&A)
1.Q : ICE & ki 4 PC?
AL SEIRT PSRRI
Step 1 : 2 & ICE ERAT A EHAATH o
Step 2 : # & ICE #2 PC t9i2 42 A R3E4F o
Step3 * WMEIREBA BIRE > RIGAT XALE B -
Step 4 : E4£[Option]>[ICE code option [3% % ROM less #) Option £ IE > 4oik &
(Oscillator) 7 X, & RC 2 Crystal » 48 & (Frequency)& $ 48R 1&J8 * R EAHREERAAT &
HIRBFRIAE RN T 3F 5 BAIEH 5 ey AERHA -
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Step 5 4o RB L BILARR - F AL E TRAIR - s 2L F Print port E 5%
Step6 : EH FERGR  REZREXTHE Y —RAUE -
Step 7 © ho R B BIEABRICH R > FIHARNE] ©
lQ:WRE&KEﬁﬁAﬁﬁﬁ’&%ﬁA?
FRT 715 R
Step 1 : #E#Z[Option]—>[CIE code option]% & ROM less #) Option #EIB ° ik &
(Oscillator) 7 X, & RC 2 Crystal » 48 & (Frequency)& $ 48R 1&J8 * R EAHREERAAT &
HIRBFRIAE » RN T F 5 BAIEH S ey AERA -
Step 2 : A& WICE ey9#dE#| 5% T ICE e st T F — 4k -
3.Q: B ICE ;e ie#t > HRTIEHMAH?
A EIRT P BRI
Step 1 : 1% #[Option]—>[ICE code option]z% & ROM less & Option %37 » 4v ik % (Oscillator)
7 X% RC 2 Crystal > 38 % (Frequency) & %A RIKIE » R EAHRERLT LHIRE AR
R RBBIAGRE  FHLRBMIEH S RERA -
Step 2 : F#x & WICE a9 45 i 4] 5% T 1 ICE A4 A F —1% o
Step 3 * 3% # 4% ICE Lt &y EEPROM -
4.Q: Af—HERREAME ICE & » SUTHHRE @ ARAR?
A RABAGKRRALE - B EKEEICE SEHFRMRABRMK > 3% PC 2 ICE 9i2 3
BB EBRK -
5.Q : A3z Step Into & JE3HAT?
A & Project AT G MAEH] 5 L MM A SRR FZOMIEF B LB AR B 0 TR REIITH
#AER > H P BB Y Project 2i# 3% R ) 89 ICE » 4 Project P i a9 443 4] 5B 4 488 4
RABFHMAEH S L BRI A AR -
6. Q : & RIRAS Rt EHMA NOVELL 38 b - BTHPATIF — EFaFHH14E?
A B A4S R AT @3 ARIE R IRAKE > OBJ #% > DEB #% (P48 )R $187 > B sbiE /A
Project # R RIRAEHK AR —E T L FHE L EMAMB LR AL B Ty @ EH WICE
RELEFMRAFREE -

61




