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IAR Embedded Workbench for ARM /& IAR Systems A @] 4 ARM A BLES TF & 1 — AN EROT K34 CF
&A% IAR EWARM) . EEARHARK ARM JFRIAED, IAR EWARM B N1 5 A 7 RN QAL 5 e 2%
R MR AT 5 24 ST BOEAE T ARM 85 5 T AAT I RIS

IAR Systems 24w H RiHEH 195974 J& IAR Embedded Workbench for ARM version 4.31, Jf{t—4
32k ARAG PR H A PR K IE 25 AR R VR A AR . A SR I T A AT BL B IAR 2 (R )
www.iar.com/ewarm 5% 7 FlJ B 145 B 28 = 14 /935 www.manley.com.cn (A k) 2 SRR R 8.

IAR EWARM 4 & — AN BT (simulator) o AN T ZEAT T A S RE T LIS - F ARM
W% ShER s EE A P I I RIS AT A . AN R BT i ATPPAY IAR EWARM (R D BEANAE ] 5 ik

PATT G A B (1) X AP ] 7 45 R SR VRAL AR R 2 e H % C:\Program files\IAR System\Embedded
workbench 4.0\ARM\tutor & A, —2—DA4 IAR EWARM I{ER 7k, %#FERH THA C
WS T, tutor.c Al utilities.co EATTAFUEMTREE MBELEOCIE, T LAS 48 ri (94 3B A 00 PRI 7 58
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RATH

2006 T rg 5t

fff: EWARM (% 2] 0

N EWARM 32K 2 S ik

HE www.iar.com/ewarm -> Online Demos, F2#% Flash %z 82 F 8 FH 3 iR ;
AN T F- WS & S H i iR, AT 3R I N T 125 2

TERA 2235 H 5% \arm\src\examples |, S-SR 1K) I FE 27 > 5

FIREI 1. W3 J-Link 0 SCas MTF A SEEAERE A b A AAD IS AT A i

AIRETR 2: WYL AR AR (JAR EWARM R AR R Gi gt 5 Szt ) —H, WA,
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F—%= EWARM S5TT K5 K BCE HAs

IAR Embedded Workbench for ARM version 4.31 J&—/ME4 ARM Ab3#48 A2 BT R AT, A0 5 1 H 45 3
A R PR TSR RTOS M TR, fEiINE R o LUEEH] C/CH++AL 4 th 5 7 (T Kk
AN HFEF . IAR EWARM (1) 32 A4 -

> TiH A

PN RS

LA IAR ARM C/C++ Compiler

IAR ARM Assembler

1 4Nl # 1AR XLINK Linker

IAR XAR 1 XLIB % f2 /7 Hl IAR DLIB C/C++i&4T )%

IAR C-SPY {ik#% (Jeidh i mdits 5 ik a8)

T AT S IR

YV V V VYV V V VY

LUR A4 — T EWARM 4.31 JAS S JEAT R RE A 1) — 2845 5

1. 1AR EWAM #A IR R
@O EWARM 4.31 iR 3EAKs /i
> 58N ARM P FF
- o FE R ARM11 W (ARM1136J, ARM1136J-S, ARM1136JF, ARM1136JF-S)
- LS HAD ARM
v ARM7 (ARM7TDMI, ARM7TDMI-S, ARM720T)
v ARM9 (ARM9TDMI, ARM920T, ARM922T, ARM940T, ARM9E, ARMO9E-S,
ARM926EJ-S, ARM946E-S, ARM966E-S, ARM968E-S)
v" ARM10 (ARM10E, ARM1020E, ARM1022E, ARM1026EJ-S)
v' XScale (XScale, XScale-IR7)
> N AGHER U R SR
- SR 4T ARM ALFLER ) CIC++FI G i o5 A 7547 % i XUt
YHEIS ) 4T Analog Devices. ARM. Atmel. Cirrus Logic. Freescale. Intel. NetSilicon.
OKI. Pnhilips. Samsung. Sharp. ST #1 Tl
- 3 ¥F Analog Devices. Atmel. Freescale. OKI. Philips. ST A1 TI £5] # %) ARM AbFE 2%
Flash Loader £/
- AR T 200 RAMRESEIRE, XN TS AR A, 4T \arm\src\examples H 3k R
> NSOl T IR AL, B TR RS EE
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X B AR N RAE RS SCRF
- B OSEK J544E R4 1) OSEK Run-Time Interface (ORTI)
- B2 FE OSE Epsilon RTOS (1) Kernel Awareness i
- WS EE embOS. SMX. NORTI 5132 £F
VRS K G R T e
- XTHERE AT I I D) e
- P& 1AR J-Link 1) BL2% 180 4 h ik
v J-Link TCP/IP Jix 55 #%
v AR A IAR J-Link 47 BAR VR FIEC &, ST ARM AL BEEE 1) 2 B A
- XF 1AR J-Trace {jj ELAS B AL 4 1 1) SCHF
- {E C-SPY Bl#s th al $14T Trace 14U
- eI L2 Wi Flash () Flash Loader /%, LA Flash Loader JT & 45 5

@ EWARM BAFAEL 0 SCHE 5 s

>
>

YV V V VY

SERIIS) T ARM AR HE B CICH++RNL it 5 4G 25 A7 o o2 SUCAT

KEE S THRA XA RIEE SRR, AR A By, AIERE, PR s, 1rhf
AL 1/0 4

STV AR OIRE, 4% IAR. Analog Devices. Aiji System. ARM. Atmel. Cirrus Logic-.
Freescale. Keil. OKI. Olimex. Pasat. Philips. Phytec. ST Al Tl &%) K kK

SR ARM 2 Thumb #0F K4 4G 715 N TR P

RSB B BRI FAE ARM B Thumb £ 8T 4 1%

AR VEP i) 50 f AL B 2R A
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Flash Loader F£J¥
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3@ EWARM % s i) #4445 10,

> SRk T G PR LA R ET X0 E A PR gt PR A A S A7 A 2 LA D e

> REIEATEE, U AT DR T AATECE, RS

> RIGIAFREERAEN],  FOVFVEAN I A AR A E A 73 e -

> BBRANTEZL R EON AR

> CIC++AZ &R R BUEHEIN 42 Ry R AL A A
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SEATE R IIRARRD R R G R 7 R 2

e AARIPAT IS CGREC FH 208 10

221 AR RS 4 D 1

F= 5 1 E s AL Be

Locals, Watch, Auto, Live Watch il Quick Watch %545 & A 7 % I
TRt A R

SCHE STL 7248

CIC++HHIARE 1, [F]IN 3 i) DL 7ok Bk N 1) R 4

Wi P L AR ATAR pR RS SR i . R AR, B AAAs . RRAF ML E H, LR
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IAR J-Link JTAG #: 1 (3ZFErf5 ARM7 F1 ARM9 #%, it USB % TCP/IP %4

IAR J-Trace JTAG #:1 (CGZErfir5i ARM7 F1 ARMO #%, ik USB 5 TCP/IP #:4#2)

RDI #: 12K %8 =7 fli H.#s (Abatron BDI1000 & BDI2000, EPI Maijic, Ashling Opella, Aiji
OpenlCE, Signum JTAGjet, ARM Multi-ICE %)

Macraigor Wiggler, Raven, mpDemon 1 USBdemon %5 i 4%

EPI Jeeni {jj FL#% 32 FF
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BAERS IAREWARM | 157 =7J5 RTOS | R
L A SEL
CMA-RX X
CMX-Tiny" X
uC/OS-lI X
ThreadX X
RTXC Quadros X
Fusion RTOS X
OSEK(ORTI) X
ENEA OSE Epsilon X
MiSPO NORTi X
Micro Digital SMX X
Segger embOS X

At RTOS {2/t C-SPY e —HUB I & 1, Horp i B 1R AR 55 s AR AR o 11, AR
T ] DUE R E TS L BCE T i MIBATRE R o e AN R B I & ] BUR 7R RTOS Py 8 45

IR, BlanEnrds. BRI fE5 8. BHEMIRATAE.

@ EWARM KA AR BT A 56 1) S TR 0

oY JEIR I TR R

[F]— AR A VA A LR

CIREEA R P IEZ

PEARHE Y

AN ZESr PR ) TR

AT LAFNYEARAD 45 61 3R ZeAH A A

SCA G

- SFFZ AR QT

- BRSO B RS

- R AEE A

- JuBR I undo/redo

- BT B RS

- Goto
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IAR EWAR B A ']
- BEIE SRR
- BREAAHE
- SRACLA G0 A PRI i /i 1] )
- AT R BB AG BRAE BE/ZE 1E
> AT ERERR TR

JI R A R ]

EWARM 4 P15 5 Mk

> I1E ISO/ANSI C94 Cififg —4E )\ CO9 ArifErh PRIk AIHF ) FrvEf) C i

> A CH+y R, SRR ZEARRRE Ik AR 4475 ) LS SN IR T I ) A7
PRIFRI CH+RrtE o S8R CH+ IR AR B . WSeE, DURARUERBTRRE (STL)

> |EEE-754 7 fiia A
MISRA C 55 38
SCRE R T ARV AR G SO A% 2 (i ELF/DWARF) 5 R 2 50w WL A 28 F 475 52
Ly

© M)

S IR AN TREARAR o
NSOGB B AR S8, Al A 2 e B 1 T g
VRIS IR Fig e, AT VRN step-by-step HifE
K PEIRMUR I R A5 SR A R

YV V V VY

2. IAR J-Link 1/i A%
IAR J-Link /2 IAR 24247 5 ARM PRZE FHEH K JTAG J5 20105 L% . it & IAR EWARM £ /8T & FR
BE R ARM7/ARMO A% 5 1 (045 2L, Jo T AT 3R 5 R 7 55 EWARM SR BT R IR 85 0 4% 1442,
B, R WS R TR ARM Sl d STk TR

RIS, S AT RO 75, J-Link H 2 RIS dh b 8 S e R 1) J-Tag 15 5 4%

XS IR AR
AT 77 i WO YRR A ) AL
A g
Macraigor | Wiggler LPT ARM7/9 16 KB/ I B D4 3k
Keil U-Link usB ARM7 28 KB/F» G
IAR J-Link USB 2.0 ARM7/9 600 KB/#b H

@© J-Link ARM = E2EE £
> IAR EWARM 8T KA o 481452 (1 JTAG 15 Ho 4%
> SCFFPT ARM7/ARMO A% Fr, A0 4% Thumb #25K

TR A R A ]
B TTHMS G 5 17 5021 —)(210003)
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IAR EWAR HREA ]

JI R A R ]

N HE ik 600 kB/s

i JTAG % 12 MHz

H bRt b Va1 1.2V — 3.3V
H 3l R D e

64 4 R

181 USB H1 5t

M USB B AN 20 S5 i T 12
YHEEZ JTAG AT
FRvE 20 5 JTAG 1 H ik

ERC 14 15 JTAG 1 Hidi &
TEFCH T 5V HARHR 1 iG El #s

> 7 J-Link TCP/IP server, fifil

YV V V V V V V V V V V VY

WA JTAG 15 5 F1 H B s

ik TCP/ IP W& J-Link

@ AR J-Link 143844
J-LINK —¥ilied USB 5 PC 4%, 5 —imiliid FrifE 20 (5 JTAG ikt HARBGERE. B 5L
EH: J-LINK 2 PC,i%4: J-LINK B HAR R4, Hfash ARGt (Wi BHbr RGeS AL
MmAEH J-TAG FAEHLFIE L)
@ IAR J-Link TZH AR
Uikt I USB fitra A < 50 mA
LAV USB 2.0 4%
H st 1 20 5 JTAG [ (145 ITAG L&
J-Link I ARM [a] H A7 A& ride 5 i 12 MHz
SCEFH bR 1.2 -3.3V (5ViEhitskiks)
AR +5C-+60C
AR -20C-+65C
FXHERSE (e KD < 90% RH
AR 100mm x 53mm x 27mm
Folt (ANEHED 70 5C
HLR A7 E (EMO) EN 55022, EN55024
@ HFFIREV L5 IE AC A5 1
M EHPRRGN BV IR RGN, W] J-LINK $24L) 5V IS RC ek F. X1 1.2V~3.3V i
A4t, nTLLEBATH J-Link. A IPREERL S 20 i85 IDC $isk4fi1dE J-Link [¥) 20 (034diee, FR i
P HARIP) 20 385 i ~F- L 2470 338 10 P 1) 4 e o
V IR e 2E i H AR L (3.3V~ BV), HLjii<20mA, 17— LED a7~ IR E .
TR A R A ] Hif: 025-83235502
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IAR EWAR HREA ]

® JTAGHE:LE X
J-Link 1) JTAG 20 51 IDC i3k 15 ARM 24 & (47 L%k i UM, 55 R

JI R A R ]

51 e Ji ) I fe Ak
1 VTref Input | HIRRASH W%
TR A Fbs RGUE A, FEP=E— A P45 J-Link P ERE
Ao KT JE R R P A 4 H AR B IR o T | B 5 H BRI
vdd Bk, RS o s e R
Vsupply NC J-Link AHBESA, 6 Hbs R ERS] Vdd 8T
NTRST | Output | JTAG &4z, J-Link #ithi4y HAR[) Reset {55 .
M H RS H AR CPU [ nTRST 51, H ks N B _E 7 3w i i,
B AN AT
4 GND - AFH.
5 TDI Output | J-Link %4 HAx CPU (1) JTAG #idls .
M3 5 HAR CPU (¥ TDI 51 JAIARE . @CE H AR Kb E 47 %1 vdd.
GND - AFtHh.
™S Output | J-Link %4y Hbx CPU 1) JTAG B B 155 .
W5 HAR CPU ¥ TMS 5IHIARE . EEUCE HARBR FRe e E .
GND - AFtHh.
TCK Output | J-Link #irth#s Hbs CPU 1) JTAG 4155 .
W5 HAR CPU ¥ TCK 51 MIAHE . EIAE H bR ERE I E .
10 GND - AFtHh.
11 RTCK Intput | H#s CPU 4245 I-Link fJMRRI£{5 5
AU HARER ITAG N 50 At il . 3-Link R FH e
N A H P ) TCK %,
HAMEHILTIRE, 75 AR R e .
12 GND - AFH.
13 TDO Intput | H#¥x CPU i&[HIZ: J-Link BIER(E 5
WH 5 HAx CPU () TDO 51 IAHIE
14 GND - AFH.
15 RESET I/0 H#x CPU Reset {55
16 GND - AFH.
17 DBGRQ NC J-Link AT, 78 B s Rkt DRI % .
18 GND AFtHh.
19 vdd Output | +3.3V HJHAH
20 GND AFtHh.
TIR AT IR A ] Hiif: 025-83235502
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IAR EWAR HREA ]

JI R A R ]

® JTAGH %
J-Link APy R e, BRI e JTAG EFE . H3) JTAG M, %) REEDIA T Project Options ->
Debugger -> J-Link $ & I,

[l 5 JTAG 38 &
H b B B £ 5 BN BBUE o HBR BT IR JTAG BRI 1 H bR 11 5 o — kil ANl JTAG
RV 24 ARM W% (it ARM7-TDMD fESRAT 55 CPU BEBEAH ™ f¥) JTAG B BE . Ty JTAG [A20

BT ARM M (5l ARM7-TDMI-S, ARM946E-S, ARM966EJ-S) REHhATAH Y CPU H/ 1/6

Az JTAG
1 TAP #5751 28k 65 KA JTAG B . BEa, A RS2 A ARM W] fess TAEARTGE .

1 JTAG M. JTAG AN L 10 MHZ.

Ay CPU WX B r] BEMS T K JTAG HE /.

Mf: J-Link 2B 4345 &

HiX BER : I8 H
b JE3C ) JERUHEE X A 118 5403 F T3k B193 4R 010-62562744 | 62526647
KHETH) FREEFIF IR ¥ 1L VE3HE 323 SHY 1 5 022-27376292 / 27471810
g EINJTH) IR PR JEM LT T 3 # 3B35 #H 0755-83681644 / 83681644
IRYI TG rp g AR T T 5 H 20A257 45 0755-83687350 / 83665281
LW TN TR R R B e 56K 5L 3k 506 % 020-87588300 / 87543761
IR IR WAL RUR B A% B T 2A19-2A20 AR 021-53081472 / 53082644
GRS AL =R 347 = 021-54904533 / 54901862
3 T F) T RV B MR BT P e AB29 A 025-83615784 / 83675529
R L ZR B 110 SAHEJE R T R Ik 4% 96 # #iH 025-84412638 / 84412638
BUN T3 F) BUNE = % 639 S hUM HLT 1145 1C205 4H 0571-89901205
[ V522 )7 F) P2 PE R HL T I3 2 7 C [X 2C033-035 029-88221873 / 88270877
Fb PLRH TR PLPH =45 90 5 T IV RHEE T 1 B [X-W35 024-83991288 / 83990602
Herh HBT A PG B Hi % 158 SAEh gk 3098 & 027-87654225
Kb i F Kb AR 9 5 E MLk —# H23-25 0731-4175141 / 4175141
ik W) TS i 67 5 10 B 00852-27303434
TIR AT IR A ] Hiif: 025-83235502
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IAR EWAR HRIE A ] TR FAERAFR

%" 7£ EWARM A4 gli— AN 535 H

EWARM 2350 H 3T HRY, et 7 N R P AZERE R 00 H AR . I00H T 1] LL23 28R 53 4 BRI
. RVFNEATHE X AR EA LR (build) BE . EAERBCEIH Z /T, g AN T
fEIX (Workspace) o — A TAEX T ARVFAFI— ek 2 AN H .

T3 AN P S e g ST — AN I H SR AR A SR E SCE e Bl 7R AR R 3RATT AR c— A~ C:\Program
files\IAR System\My project H 3% . BILZEXT; 52 1 ) IAR Embedded Workbench 45, H# IAR EWARM
FRIELE

1. AERUH TAEIX (Workspace)
YEFE 328 File > New > Workspace 4= i TAEIX .
2. AERcHIH
@ EFETSEH Project > Create New Project, #AHVERGHIHE O, LK 1.
APEFET H A (Project template) H'ff] Empty projecto
x|

Toolchain: |G

Projecttemplates:

- Ermpty project
asm
B Ce+
B-C
Externally built executable

Description:

Creates an empty project

QK I Cancel
K. Ao H i
@ £ Tool chain #HIEFE ARM, SRJ5 rids OK 4441 .
@ LEFH ) A7 R T O R S AERERT 10 My projects Hk, HIASUAFE4 projectl, RJEIRAT. X
I 7 o %5 /e 111 Workspace 7 I H UK BRI H 4. LK 2 ok

SR FATIR A7 HLi%: 025-83235502
P TR ) % 175021 — )2(210003) fEE: 025-83235501
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IAR EWAR HRIE A ] TR FAERAFR

ID ebug E]

Files AES
Elprojectl - Debug * v

project] I

K] 2. Workspace % [

TAR EWARM 32 (L fldleas (035 H A2 il &, B! Debug 1 Release. ASfIl{E Workspace % LITRERH
b Hrp &L Debug. FIAE My projects H FE/EM— projectl. ewp X1, XY
projectl Wi H & &H RMMEE, W build M. WHA G LR * 588 % TAE XA AR HIE %
B YR

AEIHH printf FERE, IXJELE C-SPY B I — MK write BR%. WA Ay BEAE BLSC A
fF EPL release Be &S ATHI ¥, SAZNEE M LA F G L) write BRI EL.

@ A7 LAEX
JeEFE TS File > Save Workspace, JI T4 My projects H ko SR¥G TAEX LAl tutorials
i File name By AME, JZ{RAAIEHLEE . XHAE My projects H PR A —A tutorials. eww
A, &SRR TIPS tutorials TAEX AT ITH o B I mURCE 55 5 S i A
A I HARAS EI AR5 TE My projects\ settings H3 FSCAEH,
3. SHRITHEN IS

ABEATH R arm\tutor H & F PR SCHE,  Tutor.c A1 Utilities.c.

Tutor.c &— U EkrYE C iE S R SRR . & H Fibonacci 41w+ AN By Gt — AN, FF4e
45 BLYTE1 3 stdout;  Utilities.c {4311 Fibonacci 241 i1 52 HFE Y .

IAR EWARM SevF 2Bty T NS4 P T DURE T H 7 2R 4123 B RIS o (BAEAG] AT

O 7E Workspace Tt A HNINSCAE) H M, AT LU I H s SO . A H#22% projectt .

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501

11



IAR EWAR HRIE A ] TR FAERAFR
@ EPETFEH Project > Add Files T TFARAERI YL E 11, LK 3. MEFEZ3E H 3 ARMVtutor R 11)_Lik 2
AN, AR, A1 R Project!t H R .

Add Files - projectl ilil
EHFERE (1) : [ tuter = +®EckE

X (W) ["Utilities. ¢ "Tutor. < | T (0) |

SRR (D) [c/or+ Source Files Gk.cif.cppik.co) x| B

K 3. ishnscfd

4. BEEIH LM
P FSGRT I H RS NSO Y 2 T H BB AT o IAR EWARM FVFAATAT— 2% H s A S AF Sl B ik
PE, AEGE P 2500 AN T H BB H] A4 4% (build) AT

© P %L
1% Workspace 111 project1 — Debug, 28 J 1%+ 21 . Project > Options. th 7] LA Jti%#% project1
— Debug, AR5 1L bR A B A2 K Options.

Options for node “project1™ E I
Cateqgony:
General Options
CAC++ Compiler Target | Output I Library Configuration | Library options | MISRA C
Agzembler P ant
Custom Evid TOCEs30n varian
Build Actions ' Core ARMTTOMI-S
Linker
Debugger = Device IF‘hilips LPCZ2108 'Ek_l
Simulator
Angel FEL

14R ROM-monitar

J-Link INUV"E 'l

M acraigor

ROl ¥ Generate intenwark cade

Third-Party Driver Proceszor mode Endian mode Stack align
0 & Little * 4 bytes
@& Thumb  Big 8 bytes

oK I Cancel

4. T H G A f

FEFTIT ) Options % 111 /241 ff) Category H1i%#% General Options. 4R 23 I 4E :

SR FATIR A7 HLi%: 025-83235502
P TR ) % 175021 — )2(210003) fEE: 025-83235501
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IAR EWAR RN ] JIRIE A R A ]
- Target Uit [fii/Core 4% H T i+t ARM7TDMI-S
- Qutput T, Output file 45 H Fi%#% Executable
- Library Configuration Ui[fii*", Library & H T i%$: Normal

@ EFmitasitir
1t Options % I1[1) Category H1iZ#¢ C/C++ Compiler, L& 5.

Category: Factory Settings |

General Options

i C/C++ Compiler Language Iﬂplimizdhnl Elulpul] List | Prepmcassol] DiagnoslicsL!L
Aszsembler
Custom Build
Build Actions [k
Linker G.C
Debugger " Embedded C++
Simulator " Estended Embedded C++
Angel " Automatic (extension based)
|&F ROM-monitor
J-Link [™ Require protatypes
Macraigor Language conformance ~ Plain 'char' is
RDI _ = Allow |AR extensions " Signed
Third-Party Driver " Relaved ISO/ANSI @ Unsigned
" Shict ISO/ANS] '

[~ Enable multibyte support

| ok I Cancel

K] 5. C/C++ Compiler L% I

SRIGAE:

- Language Wi, #%F C, Allow IAR extensions %%

- Optimization T, 4% Generate debug information

- Output Ui, %+ Output list file A1 Assemble mnemonics

- List U, & Output list file. 1% $ Assembler mnemonics F1 Diagnostics
-l OK HH,  HAE R Ik

FEBCEIH L& DA V2 HALE R T AR, Fr DA SO ey 25

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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IAR EWAR HRIE A ] TR FAERAFR

B HmFENMERNAERF

K Dgm B AIER: (build) IHFEF, RN AR — MBS 1RSI (compiler list file) Fl—AMEHz8547
2 E A (linker map file)

1. GmiEds SCpF
@ %+ workspace H utilities.c A«

@ P Project > Compile, kT H.47 ) Compile 241, miii A4 )5 %4% Compile fiv4 . Zwix
SEREAEN B DR I 6 MR

Messages

Compiling

utilities.c

Generating Browse Infa

Daone. 0 error(s). 0 warning(s)

Kl 6. Build & F1 P i) g 1AL P B
@ JHIFEFER 72405 tutor.c.

i 1R 58 UG A5 My projects H sk M A2 e U1 H 5% o A FATTE L S7 7 501 H I 1 # Debug B,

Jit LAZE My projects Hxt A 8h“E#—4~ Debug 1 H 3%, Debug T Ha% F A& 5 34T Hk, 4

T4 List. Obj. Exe. EATHIHELIFR:

> List HsfA7r NIAIRICAE, BRI G 4802 Ist:

> Obj Hz& N7 Compiler 1 Assembler A= A fF) H AR S, XX B ORI 480 r79, 7T LAUHAE IAR
XLINK 425 R AN AT

> Exe HZ FAABOTHAT AR, XL E A d79, W LAHIAE IAR C-SPY Y48 15 A SC A,
HERAEPATEBA L 2 JX A H % 225 1

rithi project1 — Debug R [ [ +56 H sk e T o /R 1T LA B3 A E 1) Output H 3% H & 2 A A Bl 1)
a0 SR 4 DL R S R EL R R AR IR S SR 44

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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IAR EWAR HRIE A ] TR FAERAFR

Files I

Eldproject! - Debug | v |
21 [ Tutor.c x
—3 [ Output
— B Tutor.lst
': [ Tutor.phi
@ Tutorr?9
— [ Tutorh
[ Utilities.h
& @ Utilities.c
3 Output
[@ Utilities. Ist
F— B Utilities.pbi
L [ utilities.r73
— [# dl4tptinlén.h
— [ DLib_Defaults.h
— [2) DLib_Producth
— [ stdio.h
— [B) Utilities.h
— [&] xencoding_limits.h
— [@1ysizeth
— [E)yvalsh

project] I
K 7. G PE AL B S SO PR S R

2. HHEHMIFEAIIERCF
IRAEFRAT 138 I SR G A A A AR 2] (Optimization) SKWLER list SO aifel B 20 58 A i 4%
R o

@ list L4
il Workspace & I H1 1) Utilities.Ist, 4T7T list 301, BAELL R EA:
> Uk — WORRPERSIIRAE R, SRS SN ], source S list SCAAT object SC
PR T RERAE, it AT ORI 5E(E B
> SR — ORI RESRURTE A AR I G A RAD R AR, DA A e 4 T AN [ 1)
B.

> PR — WorPril R R AR LU B A A AR R R, RIS R A A R

@ EFTZEH Tools > Options 3 i} IDE Options %1 % 1, 1EF¢ Editor i [f. £ Scan for Change
Files 1ff. Mk A a7 FFgmi e 1 (s, Hii Utilities.Ist SCPF . 3% OK 4 .

SR FATIR A7 HLi%: 025-83235502
P TR ) % 175021 — )2(210003) fEE: 025-83235501

15



IAR EWAR HREA ]

JI R A R ]

weoptions @
Editor Setup Files I Editor Colors and Fonts I
Project I Source Code Control | Debugger

Cammaoh Fonls' Key Eindingsl External Edlnrl Messages  Editor

Tah size:

Indent size;

— Tab Key Functior:
 Insert tab

& |ndent with spaces

[V Syntax highlighting

M Auto indent
Configure... |

[ Show line numbers

¥ Scan for changed files

[V Show bookmarks

EOL characters:  |FC

[~ Enable virtual space
V¥ Remove brailing blanks

-

]

Cancel I pl Help

K 8.

IDE Option %

@ %t Workspace 7 HH ) Utilities.c, 3% flbnAT BEIE R HHEH 1) Options.... MBI X TEHE A
111f] Category H1i%#% C/C++ Compiler I Override inherited settings. ] JF Optimization T,
Lt 23 M None B0ie ok Higho #8514 OK %4 .

@ FFrgmTE Utilities.c, T RX NG A DK Utilities.Ist ST 24 HENBR BT SR s AR
P NANSEASK WA 2SI BN ETINN T

® XA T, Optimization NMiLHE None. Jr ARG AbFEHT M AZKE AN A B R I B
XN EH Utilities.c, % B b A7 BEE B3 B AE - ¥) Options.... i&#¢ C/C++ Compiler JFHH
Override inherited settings. X5 B B4 Utilities.c.

3. NI

@® sk Workspace % 1141 1#) Project1 — Debug, #&J51E$¢ 322 5. Project > Options, i} Options
XUEE 1, W 9. 7EZCil) Category HiEHE Linker, Z7n IAR XLINK 145 3E £F DT T -

TR A R A ]

P 5T BB T #6175:0218 —J%(210003)

16
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IAR EWAR HREA ]

JI R A R ]

Options for node “project1 - Debug™ E

Cateqory:

General Options
C/C++ Compiler
Agzembler
Cuztom Build

¢ Linker

Debugger

Factomy Settings |

Output | Extra Elutputl th:lefinel Diagnostiml List I Eonfigl Proce A I "I

— Dutput file
[ Overide default Secondarny output file:
Ipraiect'l .dr3 [Mone for the selected format]
— Format

' Diebug infarmation far C-5FY
¥ with runtime control modules
W with 140 emulation modules
[~ Buffered terminal output
I Allow C-5P-specific extra output file

r
Bifer [Hutput format: I elfdwarf

Farmat wariamnt: I,L\rm compatible

Module-local symbols: IIncIude all

Lef Ll L«

=]

Cancel |

K 9. XLINK Z k4 1

A 4 PR T A FRE FR AL BRI A o AER A T S0 — T i SCPRRS 3 URN Linker iy AT SCAFIIEFET

%

& g

JIFIHTH R A A
F T HTR S 5 175021 —J2(210003)

BV, g L (O w0 W M R SO TR 0. B . = 1 A 1 WS = O 1 2 R 17
A A RS S AR H IE A C-SPY A #% sk 48 4 th 1L, 'E A1/ Debug information for
C-SPY. With runtime control modules F1 With 1/O emulation modules. $5/~x7 %1430 stdin
stdout 45 1] C-SPY 1] 1/O & I [FMK B 2

R P A EIE N R3] PROM grfgs i, T H 4 A 20 75 295 A5 &, W Intel-hex
1k, Motorola S-records.

7E list T %+#% Generate Linker listing Al Segment map (WL 10) o FoiFAdz lififit 2% 20 il
MAP 31,

TED AR iy SO Y 5 AN AR TR € ORI A R EWARM S R R g iy & S0 F
Bt A AU (simulator) FPAEH] . A2 QR EHEEATH T HAR RGN 2505 SERR I
WA A A ARIGERC . F P AT LA, ..src\ examples H s 4% 21 5 PO G 1) 1E #6285 i 4

Hi%: 025-83235502
{2 025-83235501
17



IAR EWAR R[]
A

JI R A R ]

& AR
FEER A T 3T, HITBe (segment) #2HH) XLINK 4702 R IBCE Bei) . AGRIERE ds iy

A A RB A Ty . 1 LA ARM IAR C/C++ Compiler Reference Guide H T it 5
ZfEE.

A ] A8 BB i S, i LI 9 &l 10 1) Config BT

P U R B AR AR o SO, W GG RSO 2%, Bl JAR EWARM (4t B ml L
ITE IR, R 5% e S A 1 5 28K

@ i OK %447 IAR XLINK 3£

@ HFE I Project > Make Bl br A Make v 4, 18 HARSCHE, AR T HUAT A0S .

Build ¥ B % H Hf SR IE B A BE T R o EH I 45 B AR A R B AR DS S
project1.d79 Fl—/{rfig#s 7 lE (MAP) (4 project!.map.

Options for node "project1" 1 il
Category Factary Settings |
General Options Output | Extra Qutput #definel Diagnostics List |Config | Pﬂﬂ

C/C++ Cormpiler

Agsembler [¥ Generate linker listing

Cugtorm Build [¥ Sesment nap File format

Build Actions Symbols @ Text
i F=—

Debugger (" Symbol listing

Sirnulator o Tl s [~ Lines/page: |80

Angel —

&R ROk-monitor [ Module sunmary

JLink [T Include suppressed entries

Macraigor [ Static everlay map

RDI

Thirc-Party Driver

Ok | Cancel

K] 10. XLINK &A1 list v

4. BEMAPIAF

X ifi Workspace '] project!.map X444, Sfaastd I 278 1% MAP SCHE. N MAP SO ERAT]
ATRLTfECL R N

- SCPESRP RERR AR RRCAS, it SO A DLRGE B i A R 1

TR A R A ]

HLi%: 025-83235502
P 5T BB T #6175:0218 —J%(210003)

{2 025-83235501
18



IAR EWAR RIZEAT] Ji R A PR

CROSS REFERENCE Bt 7%/ A H il

RUNTIME MODEL B 7 (8 H] i 3a A7 I A BR 1) @

MODULE MAP BLg s BT 8 KIS0 F o REANSTIErR, A0 N RE Y B2 I A7 S i 45
KLy AR BO RS BOh A WK 2 J5 A5 #R 1 H R

SEGMENTS IN ADDRESS ORDER B4 it 1 241 By FH A (1) A7 B it e s bk fn g it ik,
HL, AR SRR UESE

END OF CROSS REFERENCE Bt ‘s 5 A U A S 4 7 1 4

BN, C&A K project1.d79 MR I 0] LU T-7E IAR C-SPY ik,

BrE: FAETHEBAT BN IAR AF 8051 F &k TEMAER 2 423 H, HE

IAR A &4 K EAT AT o 3 8051 JF & T EAREE R, FFAEFH &l KA i 7.20¢ R EW8051 & JT
RIREH, TEEER T JI A Insight 15 B 85K RIS . BT AEEFEAR B EAME ), 5% T 4
Ll [R5 4 P AR AL AR AR B 15%-20%, IS0 TR S84 SE I 1 70 45 1K

BT R A AT e B R AT — B W BN A AT 2,900 TG 8051 JF & T HAL, s

- 1% 8k ALY PRI IAR EW8051 4 i T & Wk

-1 4 Insight 8051 {/i E. 8% (H 7 a] A JTF| 8051 R &5 E 4% HFIERL 1 3, LUEHAHE T 8051 5 F)
ZLHARHE TR A E 13 A EHA A B R1E,

BTAERAR X sl &, dE—22 A E N Ah 8051 05 1) ri S T HE AR #1155

BriE: 1AR A FE)EAMXFF ARM Cortex M3 2 H28 H, Hitdhiypesy

IAR 22 7] A RE AT T AESERTF KB EWARM H 32 #5371 ARM® Cortex® M3(CM3)4E4, X7E ARM 2
=5 T AR, AN B A SRR B 1) EWARM 4 BT R B o 25008 — AN i 46 Thumb2
TR CICH+gm e . 4 4y, |AR BAE L8k @ MG AR DAL AT i G PR 2% (BRI, [ 34 AT B
Ji ) USB 2 F11 J-Link JTAG ) E#, Jo4% ¥ Cortex M3 B ab #4517 XA flash 525 Thie

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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IAR EWAR fRIZEAT] JT R T PR

HVUE H C-SPY HiAN AT

AL C-SPY B2 Simulator) kR B IAR C-SPY {12 2% (1) LAy o BT TR %15 42 1Y) project1.d79
MR O 2 v LU C-SPY TRAZSEHT . H - A RS v DL AR & L 508 W WS B g A0
ISR 2FAE AR FIAEE 25 . 7F Terminal /O & 4T ER I .

1. JFER K
FETHG R Z HT b 2506 B LA C-SPY ko HARERAM QT

@ IEFEEH. Project > Option, %# Category 'I'ff Debugger. {t Setup JUjfil, i Driver [f) N3
bk EE Simulator, A% £ Run to main, fiili OK.
W LM T IAR (K JTAG 1 E2%, 151E+F J-Link.

@ P Project > Debug B T H.4% F i Debugger #4H . IAR C-SPY ¥ JT U444, project1.d79.
bR T CEFT I E Ak, K RoR—41 C-SPY LHIE H.

2. HLEN
7 EWARM ] PAEE % 1 (Il dock) , i af IAIZURP R, Wl Uik eliFsh. Sz sh i
IR RN HAR B VAN B2 50

FE& EWARM IDE % H 5l PR AS 4 p A o ek s AT G B . TRAIERIE S W 77 1T

Organizing the windows on screen.

FETFAR R ATE AW 11 Fos i & DA N A D8 WoRT7E b4 L. AEgmi a8 & N A 215 SO/
Tutor.c 1 Utilities.c UL f Debug Log 4 E % 1«

3. KrEriEinEa
O KEEiER, Wil Workspace 1 Tutor.c;

@ 7rEgmiEs Bos X Tutor.c &, JT Debug > Step Over fir4 (E{ F10) , L33 init_fib e& Ei 115
s

@ H] Debug > Step Into 174 (5 F11) AR init_fib;
1) Step Over fir 4 FSRPATIIRE 7P 0 — 4B A a— 4454, BIMEIX 48 1) — B0 E .

JIR TR A Hi%: 025-83235502
BTG D 417 5021 —/2(210003) {2 025-83235501
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IAR EWAR fRIZEAT] JT R T PR

1M Step Into iy 4> M3k 21 & Brak 7 F2 5108 H P 56
AT Step Into J&, WEERE L B4 D)2 Utilities.c, K4 init_fib £EIX NSO HL,

@ k%M Step Into v 4 H 2 for I E

® T H Step Over iy 2 A2 for ANk, IBVER, BUERAEREOH FH A E R g it
W) g RiER g kT4, Debug > Next statement i T H. 4% _F /) Next statement 424 . iX
%4145 Step Into I Step over Al

A 1R Embedded workbench 1DE - 1O] =]
File Edt Yew Projgct Debug Desssembly  Simulstor  Tools  Window  Help

SlelZa 228 518
S IEIEE |

1% % % [0 UA0R |

Warimate B
IDebug =
B | [ | EH Increase the 'call cownt® verisbls.
E]@ project] - Debug - s Fet and print the sszicizted Fibomaooi npumher.
Tuior.c A 2 call _count = 0
R_E @DD - woid do_fereground precess (veid| FITNOEEE 4507
03 Dutpu i 0<000020F8 3100
| | — B Tutor It unsigned int f£ib;
| | — B Tutorphi next_counter():
| L B Tutor.73 1D = get_ribf call count J;
| — R Tutorh puc_£ib| fib )z
| B Uiliies.h }
—= B Utilties.c
000003104 ZB0A
2 0 Qutput & 0200003108 DA02
a8 [ project! 478 Main progra. dn_foreground_r
(21 Output Printa the Fibomicci numbers. 0=00002108 E7FF
== mprujecﬂ o 0z000031L04 FFEGB
.. ext label iz a Th
dldtptinl3n.r?g next_counter: 7Pl
— B Inkerrn vl 'iicau P 0200005L0C ETES
i Tutor. 73 init £1b(): 0:20000210E BCO1
mut"':""fs"?g while | call_count < MAX_FIR | gzgggggﬂg 3538
projectl map do_roreground processi); izt labell i & Th
} _fib: 77xT =
= nnAM=1 14 annn
et | [fal (4] »|‘| ;IJ
x
Messanes |
Building configuration: projecil - Debug

Corfiguration is up-to-dste.

|tnaz, Col L | m | A

Kl 11. C-SPY il % 1

4. R

C-SPY AVFEEFYT EEFEALREFIAN, Jron] ST R R b ER RS AT E I & . BE AR

S TEAT LR, AEUERS S DT RPR XU A 44 . SRIG4TTT Locals. Live Watch i Auto % 1. i1

R 24 B I T VR4 S5 A 51T Working with variables and expressions.

A 2R H None RALZLI, I M AERS A RAR SN G S N ORI, T DU LA 5 58
AREW PRI AR ST S = g itk AT ReAs e ik,

Heoo

@© FH Auto & H A FH AR i

#FE View > Auto 17T Auto & . Auto & H /s B U 4B K S 1T, S HATIF
MEEA AN AL o

SR FATIR A7 HLi%: 025-83235502
P TR 5 % 175021 — )2(210003) fEE: 025-83235501
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IAR EWAR fRIZEAT] JT R T PR

x
Expression Yalue Locatian Type
i 4 R4 shart
rootfi] 0 0100074 unsigned int
root Larray’® 0100004 unsigned int[10]
get_fib 0x00005164 unsigned int (_...
< [ +]

Kl 12. Auto % 1A A AR

@ ¥ HE—4 Watchpoint, F|H Watch % 1A F 4 &
& $% View > Watch 477 Watch % 1. 1735 Watch % 1 Auto & 3% 125 B Bor. 200N
WA R LE 4> Watchpoint.

- piili Watch & HH I RBEAE, A LN i, AR5+ Enter 8.t r] LA GRS o 46—
ANF % Watch % 1.

- Xl init_fib p& & root 24144, K HAHEE] Watch
Watch % 1147 .75 | F1 root fi{H . #f root T EEES o3 A

Expressian Yalue Location Twpe

[ 5 R shart
El root <array? 0100004 unsigned int[10]
— [0] 1 0x100004 unsigned int
— [1] 1 0x100008 unsigned int
— [2] 2 0x10000C unsigned int
— [3] 3 01000710 unsigned int
— [4] 5 01000714 unsigned int
— [5] 0 0x100018 unsigned int
— [6] 0 010001 C unsigned int
— [7] 0 0100020 unsigned int
— [8] 0 0x100024 unsigned int
— [9] 0 0x100028 unsigned int

Kl 13. Watch % [

- dREEHAT R, EE TR root [N AL .
- M Watch & HHERZ: AR N, Hamkse e R E Mg .
5. WEE AR
IAR C-SPY H.AT s KW Sihft. VE4IiE WL T 131 T The breakpoint system.
T T AR T PR ) VR R s e o BN R4 TE R, AR 1R bR A IR Toggle Breakpoint iy 4. S5

SR FATIR A7 HLi%: 025-83235502
P TR 5 % 175021 — )2(210003) fEE: 025-83235501
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IAR EWAR HRIE A ] FIRHBEFAERAFR
JIEUWTR

@© wE W

M RTH 2 get fib(i)iff) FCE R AL, fEgmiEAE & 1 Wos utiliies.c. sl 2B B mifiEf), T
T3¢ Edit > Toggle Breakpoint. 1] BL4% T H4% [:f¥) Toggle Breakpoint %4l . X iZiE ) A
LW bR -

I RS W 5 SR, e 23 %A View > Breakpoint 71 7T Breakpoint % I 1. 7t Debug Log % Il
W IR ST AT AR B

Bj Utilities.c (Read Only) | (O] %]
/:{-
Initialize MAX FIE Fibonacci numbers.
i
void init fib( wveid )
( [l
ghort i = 45;
root[0] = root[l] = L:

for | i=2 ; i<MAX FIB ; i+t
¢ roori] - EENEEENE + cec tfibri-1):
'

Jful 4] |

tu

K 14, BUE KA

@ AT R W7 R
HEHE ¥ 32 Debug > Go B T H 4% FI) Go #8148 T LLLEFR 40T 27 2. Watch % 1K 271 root
KB M. Debug Log & 4B T A Ko

@ BRI
n] FH 3232 1. Edit > Toggle Breakpoint 5% il A5 471 8% £ Toggle Breakpoint.

6. fExiCgi e 1 L
M, A C\C++IE/ L Nz S PR NI S B % . (EE A R P A A S g Ay Lk, C-SPY
L TIXMIIfE, M H C-SPY SeVFy I MAE IR S BV S gnAR AR A R .

@© f% Reset F& kA7 N FHFET o
@ PABAINT S T IR AT I 1) i RE AT I T UL $E 32 . View > Disassembly $7 7 5 il 4h

.
TR T AR A A i%: 025-83235502
R TTHTE L 4175021 )2 (210003) 1L H.: 025-83235501
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IAR EWAR HRIEA ]

IR A R ]

Goto I j IMemDr_I.J j IE

ivold maingwolid) ﬂ
ext label i= a Thumb label
ain:
0=000080F4 EBS00 FUSH {LE}
call count = 0
O0=z000080F& 4807 LDR RO, [PC.#0=01C]
0z000080F8 2100 MOV R1. #0
0xz000080F4A 6001 STR R1., [RO, #0]
init_fibi{);
0z000080FC FOOO pre BL-BLX
0=z000080FE F20C L init_fib
while { call_count ¢ MAX _FIE )
0xz00008100 4A04 LDE R2. [PC.#0=x010]
0=z00008102 6813 LDR R3. [RZ, #0]
0z00008104 ZBOA CHMP R3. #10
0xz00008106 DAODZ EGE 0=z00810E

0=
o 0=

do_foreground_process( ) ;
poooalog F?FF
gooosl0d FFER

EL

pre BL-BLX

do_foreground process vl
3

P15, SOl gt 1

B4t i 15 Bras. W AR BNC4aARAS S C iR ——Xf M. FH BT LR D A AT

¥

Rt

e

7. WA A

TAr s a LAV IRAAE S CPU SR -8 N 8. AT 0 T

@O HEPFEIEH View > Register T P27 11, W1 16,

2 Register [_ (O] x|
IEF‘U Registers :!
RO = Oz00000000 R12_fig = O=x00000000
R1i = 0=x00000000 R13_fig = 0=x00000000
B2 = Oz00000000 R14_ fig = O=x00000000
R3 = 0x00100128 EHSPSR_fiqg = 0x00000000
R4 = 0xz000030FD R13_=ve = 0x001021E0
RE = 0x000080E3 Ri14_swe = 0x0000B0EB3
RG = 0xz00008005 HE8PSR_swe = 0x00000000
R7 = 0x0000804A9 R13_abt = 0x00000000
Rrg = Oz00000000 Ri4_abt = O0=x00000000
R9 = 0=x00000000 EHSPSR_abt = 0x00000000
R10 = 0x00000000 R13_dirg = 0x001022E0
Rri11 = Oz00000000 Ri4_irg = O=x00000000
R12 = 0x00008070 HSPSR_irg = 0x00000000
R13 (SP) = 0x001021E0 R13_und = O=x00000000
R14 (LR) = 0x000080E3 R14 und = 0=x00000000

-1 CPSR = 0xzc00000F3 HEPSRE_und = 0x00000000

] SPSR = 0x00000000 R3_usr = 0xz00000000
PC = 0xz000080FC RI_usr = O=x0000o00o0
CYCLECOUONTER = 3151 R10_usr = 0x00000000
RE_Fig = Oz00000000 R1l1 u=sr = Ox00000000
R9_fig = 0x00000000 R12_ usr = 0x0000807D
R10_fig = Oz00000000 R13_u=sr = O0x00000000
R11_fiqg = 0x00000000 Ri14_ usr = 0=x00000000

@ H Step Over & HAT F—5&$54, MEF

® KHMFHFARE .
TR A R ]

4 16. 2 {F AT

MR T HTR S D 175021 —J2(210003)

A B P K A2 4k

Hi%: 025-83235502
{2 025-83235501



IAR EWAR HRIEA ]

IR A R ]

8. BEAIHifids

FLa] LAAEAAA a5 B 1 AL B PR A A s DX a2 A6 A 5 A8 B root A7 R IKIAEAa  2F

@© P EH View >Memory fTIF/7fifias & 11, WLIE 17 (1] 8-bit Bor%dli) .

@ WoE Utilities.c % H 33485 root. JH BUFRKE A B 28 7 10

@ WERAHLL 16-bit Lon Bl AEAA A B HE AT Sz o B #E 2x Units fir 4.
W C MR FIY init_fib pEGAA WIGLIT A A A 3 00T, ZREERAT D, Rl ILEAF it 3 1
N BRI IE S 1P T AAEAF il o B LB S T A R . B SRN UBHE A BB AU
I RIEEI NPT A T o

@ KMAFEaR

Gaml

j IMemDry

=] [
ao oo

ooofE££0
nooffffa
oolooooo
oolooo0s
ooilooolo
ooioools
ooiooozo
nogloooza
ogilooo3n
noilooo3s

na
oo
na
01
oo
oo
oo
na
na
na

0o
oo
oo
oo
oo
oo
oo
na
na
na

oo oo oo
oo oo oo
oo oo o1
oo oo oz
oo oo oo
oo oo oo
oo oo oo
oo oo oo
oo oo oo
oo oo oo

an
on
on
on
on
on
an
an
an

nn
oo
oo
oo
oo
oo
nn
nn
na

0o
oo
oo
oo
oo
oo
oo
na
na
na

K17, 8-bit B fifilias & 1

Gnml

‘ﬂ |Memnry

EllEl

Do0fffc0
DOo0ff£dO
D00fffe0
DOOEE£ED
oo1o0000
00100010
oo1o0020
oo1o0030
00100040
00100050

oooo
oooo
oooo
oooo
oooo
ooo3
oooo
oooo
oooo
oooo

oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo

oooo
oooo
oooo
oooo
oool
ooos
oooo
oooo
oooo
oooo

oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo
oooo

ooon
ooon
ooon
ooon
oool
ooon
ooon
ooon
noon
ooon

ooon
ooon
ooon
ooon
ooon
ooon
ooon
ooon
noon
ooon

noon
noon
noon
ooon
nooz
ooon
ooon
ooon
noon
noon

ooon
noon
ooon
ooon
ooon
0oon
ooon
ooon
noon
noon

2]

9. W% Terminal 1/0

] 18.

16-bit Bz R FE A 28 i 1

F P A 0T e 25 R N FH AT T I stdin F1 stdout 4544, (R & AT SEfr (R4 52 #f, C-SPY iy
FH 48 Terminal 1/0 #i4) stdin 1 stdout.
1) Terminal /O A EAd 1 384 5o 43444 With 1/0 emulation module A4 7] . i,

B3 stdin 1 stdout 35 Terminal 1/O [R50 Rl 4t 3 4233k N FH L o

TR A R ]

MR T HTR S D 175021 —J2(210003)

25
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IAR EWAR HRIE A ] FIRHBEFAERAFR
@ EPEIEH View > Terminal /0 & 11O #AEMHH, WK 19,
Terminal 1/O & 11 W /R AN I N R P HUAT T 212t

Ternninal 10

Outpuk Leg file: Off

|

55 -
4] [
lgalis Lirl codes | Irput Mode. . |

| Eutfer size: 0

¥ 19. Terminal I/O % 1

10. PATHE/ P45 R
@© %FETEH Debug > Go s T HA B Go #ill. BT — MW, FrUREF — HRAT RIS 0.
[F] I 71 Debug Log & H R L4 BIARE T exit R, W& 20.

Log

Wed Feb 11 08:57:36 2004 Loaded module

Wed Feb 11 08:57:36 2004 Target reset

‘Wed Feb 11 08:58:17 2004: Breakpoint hit Code @ {C\Program Files\
AR Systems\Embedded Workbench 4. 0WARMtutortilities c}.27 15
Wed Feb 11 08:58:29 2004: Prograrm exit reached.

& 20. Debug Log % I
@ G HRESRE AN R, %52 Debug > Reset i T. H. 4% [ [f) Reset 44l .
® WEEE Y C-SPY, % Debug > Stop Debugging, 5% T H.4% [[¥) Stop Debugging %41 .

C-SPY i §2flVF 2 SLAR K AT RE, WIR M RIS, K AEdar AR B e . A7 Wi 11] Debug
THREMITELN I 4335 WL T-MF Part 4. C-SPY [y o 4135 WT Part 7 LULIRHLAE B 5 & .

JIR TR A Hi%: 025-83235502
BTG D 417 5021 —/2(210003) {2 025-83235501
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HiE: IAR AT KA E K ARM Trace {5 E 5% 2 H 14 [, et

IAR 2~ 7] AR KA T H ARM FF TR s — A0 b SRR % IAR J-Trace™ . ‘&S HFFT A ETM
(Embedded Trace Macrocell) () ARM7 fil ARMO 4bFESE, Jf i) 4 USB 2.0 £ 115 FHLIER:, JH4t 2M 777
[f) Trace 2247, IAR A )i EWARM REWS 584 % FF J-Trace. i% Trace 1 ELas TAEMAA 1195 o6, HiTiE
WA RAE JTAG #2111, IAR J-Trace % T2 K 2 BT K310 5 A0 r] DL E— 5 22 1) ARM i AF I U8

AR Trace #k&
« USB 3 #)j(1) JTAG Al Trace (38-pin Mictor) #£11; * Trace 3£ f = 200 MHz 453 I8 AT 100 MHz
« ZEFFTA ARM7 F1 ARMO 4b B 2% 2 T I

o O YR, R USB O fE L A AME R ;- Trace ZhfgiET- ARM ETM (Embedded Trace
 HERTE IAR Embedded Workbench for ARM #1, 5T Macrocell)

B R « Trace ¥ W& Trace bty 1 1F 3 %
« 2M 775 Trace 217

HAMER o RS, 5 TIHCEAE R
*« JTAG i % 12 MHz « LHF, JCRUE B
o AR * Y ¥F cycle accurate fil compressed tracing
+ USB 2.0 4= (12Mbit/sec) o SCEF AL 1847 /16 fiif¥) Trace ¥ I, REF
« JET RTCK JTAG 15 5 1) FLE N 1349 SR A S I 2 T ) Ao
s TSR HbR T E « %4 IAR Embedded Workbench for ARM 1,

* 20-pin kr#fE JTAG #2111, 38-pin ki Trace Mictor 22 [ Sy T B AL H
« 7 USB 145, 20-pin V- HE 451 38-pin Trace H145 « Trace % 15 Source #! Disassembly & [ [f] 2
o LR ENIIEMERSE: Windows 2000 Fl Windows XP  « Function Trace A% 432 U Hh 55 7 4% 18 FH 1) 26 34
« 5 C-SPY Uik & A p:  MEB 1) IR D e A W] LAAE

C-SPY 1 H

“IAR J-Trace 1#75 IAR Systems ] ARM F- K HE0LHT 1 REFL 2 585, IAR 2\ 7l 4145 BEWE 29 B 17 6 AN Al FrE /)
STR ARM TAFZH# M 12 LG IR o 7
Mr.Dominique Jugnon, %GR dil A Tk T 2208

“IAR J-Trace XI T-FZMIHICH 5/ KNGS RHG M. 78— 7RI TN GETD IF A ZH0TF L2 T (FH (5
9 Trace i 7%, L EE. ” Mr. Gualtiero Bagnuoli, Micronas (V<457 i v JH 45 3

CRETHKEN], 2T IR AT ARM G AF I TR 75 R o A dsi8:  “H ik —ic 754 Flash Memory
1 ARM LPFEZEHTIEH 2 AT T 175219 i R T AEA 7 5 : IAR Embedded Workbench for ARM BaseLine
IR, —BIFLRUK IAR J-Trace il 1A, BET 4000 Fx!

Mr. Mike Skrtic, IAR /A &) 7 & B4

JIR TR A Hi%: 025-83235502
BTG D 417 5021 —/2(210003) {2 025-83235501
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2 1.2 EWARM Flash Loader 7 X355

REALL LT N2

> R YRR T 308 RAM

> R AR T 48 Flash o

> MHEZLFE P AR S AR 7 A4 43 7 41 Flash Loader

ARICEAN T a4 5 IR 3 CIF Flash Loader, #5)im, 11414114 T Flash Loader HEZE API & %5
D ASCHN xx &as 2 MU, TR P A B 45

1. RN IR T EIRAMA
e R T 48] RAM R AfE C-SPY JAahilin], i C-SPY A Cfafiliir. Fril Féutitilinl JTAG
P Oe R Sk H s R 58

2 C-SPY NI, BT LTS
> M application.dxx SR AT 1 MG RIS L
> JTAG B ¥ IR A5 5] H bR RZEN RAM o,

> RUTIEE (PC) 51 RAM IR A L.

BEI RAM A (B TR P C 22 i T LLIs AT .

JIR TR A Hi%: 025-83235502
BTG D 417 5021 —/2(210003) {2 025-83235501
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JI R A R ]

IAR EWAR HREA ]

M‘“xh‘

S

application. dix
\
| cspy

/ #
& binary image —.,ll
s debug info I'-.l e /

.

JTAG connection

FC-» \
/ application
AN | target
II\ / sysrem
2. KR R #EIFlashrf

e IR T 38 Flash k442 C-SPY JRsillal, HAZH C-SPY T, TijE—hfi Flash
BAT, FRRENIRE St Flash. fEfds

Loader 1% IR/ F44T. Flash Loader 443 A %] RAM
— NI

(linker) AP MmtE SCfF, 25— AN WK UBROF AU H ARSI (44 dxx) 53

oy RS I, X

ik X H AR S (simple-code, #7440k sim) . Simple-code #% 3\
#& Flash Loader 43 LL{E H AR 1 AT (R F 256

Flash Loader &~ #i i IAR Embedded Workbench W F 2%, ] L7 IAR Embedded Workbench

PRETHIT AR

Hi%: 025-83235502
{2 025-83235501

TR A R A ]
B TTHMS G 5 17 5021 —)(210003)
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IAR EWAR RN ] JIRIE A R A ]
application.dxx — ————____ C-5PY
* binary image (not used) g
* debug information
flashloader.dxc
{ "i.‘_ * binary image
application.sim | P 2 * debug information
® binary image T - - -
b - ST
el vy - T
Ak —
JTAG
IS, S
/____,-'—-" T—
A PC-1
f application flashloader | target
|
\ | system

3.

\ flash RAM /
Rz _____f__/

24 C-SPY JHBhI, EHATEL N AR

> M flashloader.dxx SCfFH 52X Flash Loader (1) — 1 il it % ;

> dl JTAG #:10R % —dE I 2 5 8k H bR R4 RAM;

> CBRRTIHEEE (PC-1) $817) Flash Loader 7 RAM H A I 5, HFF44i51T;

> i SCfE 110, Flash Loader 4 i JTAG #2141 application.sim ST (1) B R FE i3kl %3 A
Hix 2415 ik Flash {785

> C-SPY M application.dxx A HGRIRE B, JPHEFIHEEE (PC-2) $8 Flash it v H
FNEIEE

> JEEF Flash w8 AR e DL 45 4f il LLEAT

Flash Loader/44

Flash Loader /& /1] IAR Embedded Workbench JT /& AW I RE S o HAT 9% & i ad S 110 A AL
WS PR PP B S, R4, JE5 8 Flash f7fi#i s

Flash Loader nJ LL7} A7) . — & A Flash Loader BTt HIAHEZL 7, HUEACS 1 IAR Systems
LI 5 7E IAR Embedded Workbench ;. 2 BREiR 4y, ©e—/NEHH TSEBr5RE Flash fE6if#s
[F/NEEFY . 7F IAR Embedded Workbench 1 L4840 5 7 —4H F T %85 /1 (1) Flash Loader JRZ)#2 )7 .
i1 Flash Loader IXA0FE AR B, FrLAH Pl BLEATYR S IAR Systems [ A& SCREIIE F IKSIFET

Flash Loader HEALFE /7528 T BT Flash Loader #5412 SLahfe, 08 MR 2B ik hime 4,
W P AR (M) fLi%4h Flash Loader BIALH], PLACH T 5 A H AN GUI st . GUI Tt
FEHEE . RSB 45, B TEDL T, HEE 4 Flash Loader HEZLFE /7 Fra il .

Flash Loader /544G Flash<device>.dxx [y & 41 5E . WU KR 254E 40 AR X99, N'Eff] Flash

TR A R A ]
B TTHMS G 5 17 5021 —)(210003)
30
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Loader J¥ iy %4 A FlashlarX99.dxx.

flash loader

flash loader framework
(commeon for all devices)

flash loader driver
(unigue for each device)

IAR 2~ F] ¢4 [¥) Flash Loader JARRSAL T R 41 H 5%

arm\src\flashloader\framework Flash Loader HE4LFE) P45, & APl Sk

arm\src\flashloader\<vendor>\lash<device> % Flash Loader JXzh#2) P A0S, & TRESCH

IAR 72> w2 4L AT AT 1 Flash Loader {71 R 1) H 5%

arm\config\flashloader\<vendor>\lash<device>.dxx | X/ |- &Kz F2J7 ) Flash Loader RJ4AAT SCAF

arm\config\flashloader\<vendor>\lash<device>.mac | %K) C-SPY 7 344 o W R SUAF IR 44 F Flash Loader
IPAT SCAFARIR], &2 C¥ 5 T [ 44 Flash Loader B
FERE RAM JFIZAT o AL 7 20— 48 1/0 T A7 dR AT

WA 5 RAM A REIEH AR, XN I BERAR AT H

4. nik[tFlash Loader C-SPY % 3 44
765 Flash Loader 25 A\ RAM 2 Hi ] fETT P AT— C-SPY ZR W E HAr RS, Hiln, FLeh R
£7JG RAM IEAREIES TAE, MFHEH N ERWE L ER A, DMELE RAM IEH T1E.

1E¥4 Flash Loader 3¢ A\ RAM Z i Fr AT 19 72 Wi A2 LT B =

G AR VAT JAE R 4 Flash Loader (1) H & F s

TN Y FE 44 )% K mac

%3044 NS FLOCHE ) Flash Loader 44 4[]

A b X execUserFlashInit () %K%, C-SPY ¥ 7EH" Flash Loader 51t RAM i
W Z R R B, 24 Flash Loader 1E 4 — /NN M2 Fis Ty, 2640 H
execUserPreload () #{{ execUserFlashInit ().

Y V V V

DAELP)E, fE Flash Loader iz {745 W2 J5, 1l LA 72 044 execUserFlashExit()>k Pk &2 H bx R SE 4145

W
JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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5. L5Flash LoadertE 225 Fp (1% 1
Flash Loader HEZLFE 7K 1 e ) 464k Flash Loader Xz FE 7. DL, BRBHFLT r] LLAT &R #4640 T
1, AH A /D B HE AR ey e 105 R A

FEAIEGAZ ), HEZURE Al I SRR P 10 'S R KL, A4 771545 Flash Loader. HR4EFTHI
Flash 53%, £l RET LAEMEN R h b 2 A7, LUMEAERs D BIX 5 N Flash 7 fifiait 2 i i 4
AN DX ) o HEZRRE PP 1) SR SR P i) B e — I SRR A TS 22305 5K, SCVF SRS 75 28 b X G2
AR R AR . Wk Flash Loader 9K BcAT S ot AR T4, 352510 5K T A 205

UK R AN IR AT AT A IR S A HE 2R R e . — BIRB R b R AE AR, SR sh e v 3 i iR T
FlIMessageBox () API &% n) ] 4R &85 1%, RG] F1ErrorExit () Bi%UE H Flash Loader.

FlaahDriverInitialize (arge, argv)

/N =

r \
| Initializer |
\ FlRegisterWriteFunction(write_ func)
— 4
flash loader flash loader
framework driver

write funciaddress, byte)

write one byte, repeat for all data bytes

Y

|I Data pump I| write func(0, -1)
| !
\ / flush buffered data in driver

h 4

6. Flash Loader®k s f v Sl
A R U] Ay 9SS Flash Loader BRBNFRIT. My it WL, %0 4 AT HUR 7 2 G Fe
(¥) Flash: n] LUT—AMRISEI Flash 503, 78— UERIE— AN 15 N Flash f7#35 . ABIEER T
UARTE U] P R IR, IR B T8 IS AT R I B

KT BRI B X 220 f) Flash Loader, #iZ% IAR Embedded Workbench JiTz:%¢1) Flash
Loader JX&F )74 CAS o

// Flash loader driver example.
#include <stdio>

#include <stdlib.h>

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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#include “Interface.h” // The flash loader framework API declaration.

// The CPU clock speed, the default value 4000 kHz is used if no clock // is found.

static int clock = 4000;

// Write one byte to flash at addr.

// If byte == -1 the flash loader framework signals a flush operation
// at the end of the input file.

static void FlashWriteByte (unsigned long addr, int byte)

{

unsigned char* ptr = (usigned char*)addr;

if (byte == -1)

return; // Simple return when the flush operation is requested.

// Insert device specific instructions here to enable write
// access to the flash device.

*ptr = byte; // Write data byte to flash.

// 1f some error occurs when writing to flash, this can be
// communicated to the user by using code like

// if (ret '= STATUS CMD_ SUCCESS)

/A

// FlMessageBox (“"CMD_ERASE SECTORS failed.”);
// FlERrrorExit () ;

// }

// A message box will be displayed by C-SPY and downloading

// will terminate after the user has clicked the OK button.

void FlashDriverInitialize(int argc, char const* argv[])

{

const char* str;

// Register the flash write function.

FlRegisterWriteFunction (FlashWriteByte) ;

TiR - FHERA A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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// See if user has passed a clock speed option.
// If not, the default CCLK value is used.
str = FlFindOption(“- —clock”, 1, argc, argv);
if (str)
{

clock = strtoul(str, 0, 0);

7. YnitEERiFlash Loader
© # NP Flash Loader, 141 arm\src\flashloader\philips\FlashPhilipsLPC210x:
@ WHIAGE AR T A SO S B 245 T Flash Loader HEALFEF H 5% arm\src\flashloader\framework
Fl Flash Loader IX s/ H 5%
® f£i% FlashPhilipsLPC210x.c #1 FlashPhilpsLPC210x.h iX A SCHF 144 FK, 4.2 15 5 iyt A

s
@ BRSO Y AZ R S TS AR . #5 D1 FlashPhilipsLPC210x.xcl, S
Huht5E XAT

- DMEMSTART=40000000
- DMEMEND=40003FDF

S B A Ik A Z0 RE A WL 2 H ARAE A L 38571 Flash Loader U MIEE #2183 RAM ],
X E R A4 ROM Bl RAM BUAR LS 21 []— B 18] o

M FIHERR N % ORHFAE B /)N o HEZERE 7 KL T3 2L 300 705 [PAR 2 [A) o 173 BT 1T xel SO 4R A2 1
INIEI :

- D_CSTAK_SIZE=180

- D_IRQ_STACK_SIZE=40

- D_HEAP_SIZE=0

Flash Loader HE4LFE /7441 HE (heap) F1 RAMEND (YEBERZ S F HISCAF A 1D 2 A1) 474 Ay 52
enpix o KAORIE T B2 rh RS A BT A RIR AN AE . BRGEPP XN R AT RERI R, DASe iy N3k fE.
X JTAG A&hmfds 71z, PEaemtis . WIARRIRK R X /DT 266 7717, HEAURE PR 24l
g, /b T 266 7R B TERE .

19w 553 Flash Loaderfe /¥ 2 |, #EH:1%ETIWith /0 emulation modules %20 T HF . 75 31 (1% 1 SC

s Lhdxx A SCAEY R4 .
JIR TR A Hi%: 025-83235502
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Flash Loader .48 n] LI TN HIFERF F %% Flash. {E Embedded Workbench 1, ¥ I FEF 1T
£, 747 7F Debugger download option XJ i . {f§5E Flash download i1, jfik+¢ Override default
flash loader 3171, &5k Flash Loader i th S0 . ATA] 5 4L %45 Flash Loader HIZ4#nl
LL'E ik Flash Loader arguments Ak,

WA R B, s LR B 2 Flash Loader #4 N #2483 Flash.

8. 1iiFlash Loader
W Flash Loader )7 VAR 0 ¥ B AR —FF o 7245 1072, Flash Loader /7 7E1E 0 Flash
Loader ## NI I A BE IR . 2452 Flash Loader A& 5t/ IAR Embedded Workbench
AT TR, B4 RER

7t Flash Loader HEZLFE 7 A — MR EE o %8552 3L 30 ff DriverConfig.h 1w X[ C fikbi
AR, 1l DriverConfig. h #i AL & 7EHESLFR 7 ¥k U Congig.h 1. 7f Congig.h S ff
AR LUG B AR i SO VFAE DriverConfig.h i i .

FEPRAS P DL — ML i N - R P I24T Flash Loader AT JLRIAN] o B8 S HESLRE 7 i) R A 858, 0
v E LA B DEBUG. #E5 A Flash (3t a2 H] %A% 8 DEBUG_FILE BB, fEA A7
Wi, arge/argv ZHULEHUHEA TR, SHCLHUT C TALHES %A i DEBUG_ARGS fifi{':4
.

9. Flash LoadertE 227 1 API
AT/ 41 Flash Loader HESEFE 7T HRALR) APl XK Z %L Flash Loader ki, 1RZ APl A8 & ]
AN, NSRS T WA e EEme.

T R B bR T B I& . Mandatory %7x Flash Loader 3Xz) /7 A2 S b bR 40

Optional 771~ Flash Loader XzH2E)7 n] DL 75 240k Bt th SE L ki 2 . Framework 3714 26 £ A
2344 Flash Loader HEALREF M, 1138 5 AN 1% 4% Flash Loader K& F 718 H o

i AP RSP IR A S 2 A S S0 arm\sre\flashloader\framework\Interface.h 22 1.
VIuE4k R E

void FlashDriverInitialize (int argc, char const* argv);

fHi&: Mandatory

JIR TR A Hi%: 025-83235502
BTG T 417 5021 —/2(210003) {2 025-83235501
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Flash Loader X f /72w X ULk %L, Flash Loader HE4LRE Y H ‘& K41 4H 1L Flash Loader JXhF2)7 .
argc 1% Flash ZHINEH; argv 1£ifi Flash &,

Flash Az feVFilid C-SPY () Flash REION TEHER 2 KL i#:45 Flash Loader. It pg 31—~ LRI 32 Ks
CPU [l %1445 Flash Loader SXa) 2T

void FlRegisteWriteFunction (WriteFunctionType write_ func);

Hi&: Mandatory

Flash Loader 3z )i it & # i) Flash Loader HEALRE 7 M S s 4. A write_func 2110 5
4R . Flash Loader HEZLFE T h R BEE 3 Flash 5 HIXAN S8, IR IS S bk
Ve S Htkid . MR N O IE G 1, (HA g e (R erAIRER) o Flash Loader JKXafe ik
/M FlashDriverInitialize () WifjHIL%L.

typedef void (*WriteFunctionType) (unsigned long address, int byte),
UER A FE B 5 ST 5 R A BB BRI . %5 LI Flash Loader SRENFE )7 o

unsigned long FlGetBaseAddress (),

K —ANAE AL, T RAFH A IDE ik E Y Flash Sitthiik . Wi %A 6 Flash JEHbl, %
HORIA] Ofiffffff. Billn, AMD SR Flash s fFAEREAT g2 A BRI AU AR AT I 27 A7 s, 102X B
Flash Stk SEAE (2 A HUEREST — R A LS #R A1 SR AT A6 Z2H0TE Flash R, DUESAT
A fER) Flash k&g

R EAETH R

const char* FlFindOption (char* option, int with value, int argc, char const*
argv[]);

fHli&: optional

IR EOH TAEAZ AL argy T4k HRE L.

with value ZH Uil T %M ECE M T argv HOR EAFAERA LS, BH A T BOR IMZIEF I . 1%
EAIERAE argy THRBIILARCAS S5 I N — MR . WARER A A £flag WEAF, HlU--smallram, )
with_value & 0. WIRZER A — M ERIES, BlHl--speed 14600, WK with _value 4 1.
argec ZHje argv HATHZEENE, argv SHCE TR AL I IER B0, T BLE A
FlashDriverInitialize () %/ arge/argv 24,

WIERAE argv HBCH R ETEE LM, BREORIP— 2R

R with_value B4 1, PRECURIFIE A VLRCIEE ) T AOARAN AR B4R .

Wk with_value B4 0, PRECGR[FHEAVLACIECHE argv P D1FEE

int FlMakeArgs (char* args, char const* argv[]):;

JIR TR A Hi%: 025-83235502
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Hi&: framework

W/ H] spacel/tab 73 BEII 4 d, JFAM A argy FRFHREA, BANELAUCERNN T ANikfE. argy
TR AL K, MERY) args 747 H I TR AT

BEUR N argy BT FAT B EH (RRHD .

C-SPY A # N EH

void FlMessageBox (char* msqg) ;

fHli&: optional

C-SPY K fun—/MHE A H, Hrb o msg S840 SO I BT 45 8 SO R UTHATAF Qnd) 2
%217, Flash Loader K5 IESAT, H2IFZ MR & H 1 OK #2414 1k,

void FlMesagalog (char* msgqg) ;

i optional

C-SPY 5L Mik4% ) Log % M 1 msg %5 tH 1 log iHE . IHEFRFH T HISCARTRUHHATH Q)
DEIRZAT

void FlProgressBarCreate (char* title);
fHi&: optional
C-SPY KA — N4 M. Title ZH PR Bon el & & DM Ly,

void FlProgressBarDestroy ()
i optional
C-SPY Kk ML A 1

void FlProgressBarUpdate (int progress) ;

fHli:: optional

C-SPY ¥ Ml 4%, LUt progess Z4([¥IfE. progess Z4{1 G2 0 4 100. MR EU A
LA RHE N4 A% ] FlProgressBarValue () RN R AT HED (<10) , HEZEN
THb oTaG B B (8 ARAmiREL

void FlOverrideProgressBar () ;

fHi&: optional

H 1 Flash Loader HEAUR PSS 3L 4. KZHEULT, Flash Loader JRBRE v Ay 2R 1
%y PRI FESRAE 7 v (R A\ SCAF BRI . W1 2R Flash Loader X2 SEHL T & H Qi 2E
FEA, b 200 T b o IR A 1R A0 2 5%

JIR TR A Hi%: 025-83235502
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void FlErrorExit ();
fHli#:: optional
21 Flash Loader, Jf-ili%ll C-SPY iiX#s: Flash F# 4 kM.

BELTEE

int FlFileOpen (char* name) ;
Mi%: framework

SRR AT IT NSO 2 . WORAT IR iR [l A SCPR AR R AT IF R R)-1.

int FlFileReadByte (int £d);

Hig: framework

WS SR £Q AR E 4T FF SCAF A e BN 20T o IR EOR [P B AT s 2 e 3 SCHE R B I [A]
-1,

void FlFileClose (int £d) ;

Hi%: framework

R SRR £ AHSRIRIK AT IT 30T

{IAR EWARM AR RGeS LER) e BBY

HALIAR FFR THA BN Z % (IAR EWARM IR AR RGcgfe 55D , 06 422 7 27 Hidb
it st IR AR AT . ASFSELIAR A7) 4.30A FRA K EWARM JytZ0, FEAIAEE T IAR HRAIK C
G AR AR O RIS I 7%, IF4 4L T Philips. Atmel. ST &t 53 44 21 R A W 2 7 ARM #
IRAAC B SR i RE S Bl BEPBNIRCEE, AR S 2 5 SV A AN sl (R A TS, DL (ADS T H
Borifar) SR BRI, A& 20 e 105 G HA .
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